package/xen: disable go tools
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 7 Nov 2020 17:43:37 +0000 (18:43 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 9 Nov 2020 16:06:13 +0000 (17:06 +0100)
go tools are enabled by default since version 4.14.0 and
https://github.com/xen-project/xen/commit/1e13ea98bbb8369d065af4666c45c26dab5240d5

Disable them to avoid the following build failure on arm or aarch64
(when host-go is built before xen):

aarch64-none-linux-gnu-gcc: error: unrecognized command line option '-m64'

Fixes:
 - http://autobuild.buildroot.org/results/08948e4c4a88fbf09cae524949e5b656882a6e9a
 - http://autobuild.buildroot.org/results/d966585c931ca4a4ae6a854a21e07eec4c277a02

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/xen/xen.mk

index a30e80e5e7976356f274555dbf7407c16efd35f4..8f1fa7db76147b5493e1d853b8593761354928c6 100644 (file)
@@ -18,6 +18,7 @@ XEN_ARCH = arm32
 endif
 
 XEN_CONF_OPTS = \
+       --disable-golang \
        --disable-ocamltools \
        --with-initddir=/etc/init.d