perf: Add support for Linux 3.13
authorAnton Kolesov <anton.kolesov@synopsys.com>
Mon, 21 Jul 2014 14:02:12 +0000 (18:02 +0400)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 21 Jul 2014 19:55:52 +0000 (21:55 +0200)
The Makefile has been renamed to Makefile.perf; so now we check both
Makefile and Makefile.perf to support 3.7 - 3.12 and 3.13 - beyond.

Signed-off-by: Anton Kolesov <Anton.Kolesov@synopsys.com>
Cc: Thomas De Schampheleire <patrickdepinguin@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/perf/perf.mk

index 7610f3d1d6db3c789a81b074650436c14dbdc013..ffeec0282f2430ab0a2b2211ef946663e5fa881f 100644 (file)
@@ -35,7 +35,7 @@ define PERF_BUILD_CMDS
                exit 1 ; \
        fi
        $(Q)if test "$(BR2_PACKAGE_ELFUTILS)" = "" ; then \
-               if ! grep -q NO_LIBELF $(LINUX_DIR)/tools/perf/Makefile ; then \
+               if ! grep -q NO_LIBELF $(LINUX_DIR)/tools/perf/Makefile* ; then \
                        if ! test -r $(LINUX_DIR)/tools/perf/config/Makefile ; then \
                                echo "The perf tool in your kernel cannot be built without libelf." ; \
                                echo "Either upgrade your kernel to >= 3.7, or enable the elfutils package." ; \