trace-cmd: fix largefile build problem
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 30 Sep 2013 21:20:44 +0000 (23:20 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 1 Oct 2013 21:26:12 +0000 (23:26 +0200)
The source files of trace-cmd already define _LARGEFILE64_SOURCE, but
Buildroot passes it again on the build command line through CFLAGS,
which causes a build error. We fix this by filtering out our
definition of _LARGEFILE64_SOURCE from the CFLAGS before passing them
to the trace-cmd Makefile.

Fixes the warning visible at:

 http://autobuild.buildroot.net/results/1c4567a230940a5287d03e2a5c2c7afbdc64cd36/build-end.log

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/trace-cmd/trace-cmd.mk

index ada0306e3ebb5bf6cd89a4f74d2beb018afc2c1b..7a750f9ab3a931a1855c63c4b0df15ee7cfb64cc 100644 (file)
@@ -11,9 +11,13 @@ TRACE_CMD_INSTALL_STAGING = YES
 TRACE_CMD_LICENSE = GPLv2 LGPLv2.1
 TRACE_CMD_LICENSE_FILES = COPYING COPYING.LIB
 
+# trace-cmd already defines _LARGEFILE64_SOURCE when necessary,
+# redefining it on the command line causes build problems.
+TRACE_CMD_CFLAGS=$(filter-out -D_LARGEFILE64_SOURCE,$(TARGET_CFLAGS)) -D_GNU_SOURCE
+
 define TRACE_CMD_BUILD_CMDS
        $(MAKE) $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS) -D_GNU_SOURCE" \
+               CFLAGS="$(TRACE_CMD_CFLAGS)" \
                -C $(@D) all
 endef