libxml2: remove xml2-config script from TARGET_DIR
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 22 Dec 2010 17:23:39 +0000 (18:23 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 7 Mar 2011 21:22:31 +0000 (22:22 +0100)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libxml2/libxml2.mk

index d07f631a8866f6fa62fd7ba351260613eae4cd9e..2a267b2f9e683c93cfc95b9db9f4c50987e5ca42 100644 (file)
@@ -30,6 +30,14 @@ HOST_LIBXML2_CONF_OPT = \
                --enable-shared --without-debugging --without-python \
                --without-threads
 
+define LIBXML2_REMOVE_CONFIG_SCRIPTS
+       $(RM) -f $(TARGET_DIR)/usr/bin/xml2-config
+endef
+
+ifneq ($(BR2_HAVE_DEVFILES),y)
+LIBXML2_POST_INSTALL_TARGET_HOOKS += LIBXML2_REMOVE_CONFIG_SCRIPTS
+endif
+
 $(eval $(call AUTOTARGETS,package,libxml2))
 $(eval $(call AUTOTARGETS,package,libxml2,host))