package/libvips: add matio optional dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 4 Apr 2021 14:30:47 +0000 (16:30 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 4 Apr 2021 14:44:37 +0000 (16:44 +0200)
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libvips/libvips.mk

index 494392de7bb3b5c99fc2c92e7ae96b9e073655ed..990d3f386f62d68dd5881e0d35a25205b4b5d3e4 100644 (file)
@@ -25,7 +25,6 @@ LIBVIPS_CONF_OPTS = \
        --without-gsf \
        --without-OpenEXR \
        --without-openslide \
-       --without-matio \
        --without-cfitsio \
        --without-libwebp \
        --without-pangoft2 \
@@ -91,6 +90,13 @@ else
 LIBVIPS_CONF_OPTS += --without-rsvg
 endif
 
+ifeq ($(BR2_PACKAGE_MATIO),y)
+LIBVIPS_CONF_OPTS += --with-matio
+LIBVIPS_DEPENDENCIES += matio
+else
+LIBVIPS_CONF_OPTS += --without-matio
+endif
+
 ifeq ($(BR2_PACKAGE_ORC),y)
 LIBVIPS_CONF_OPTS += --with-orc
 LIBVIPS_DEPENDENCIES += orc