ifplugd: only run post-install hook when needed
authorPeter Korsgaard <jacmet@sunsite.dk>
Thu, 10 Jul 2008 08:17:39 +0000 (08:17 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 10 Jul 2008 08:17:39 +0000 (08:17 -0000)
package/ifplugd/ifplugd.mk

index c91f96c3711d251d2bb4c57fded94f2b47b2f424..570a576086c6b44c98575a311609d49694f23935 100644 (file)
@@ -16,7 +16,7 @@ IFPLUGD_DEPENDENCIES = uclibc libdaemon
 
 $(eval $(call AUTOTARGETS,package,ifplugd))
 
-$(IFPLUGD_HOOK_POST_INSTALL):
+$(IFPLUGD_HOOK_POST_INSTALL): $(IFPLUGD_TARGET_INSTALL_TARGET)
        $(INSTALL) -d $(TARGET_DIR)/etc/ifplugd
        @if [ ! -f $(TARGET_DIR)/etc/ifplugd/ifplugd.conf ]; then \
                $(INSTALL) $(IFPLUGD_DIR)/conf/ifplugd.conf $(TARGET_DIR)/etc/ifplugd/; \
@@ -28,3 +28,4 @@ $(IFPLUGD_HOOK_POST_INSTALL):
                $(TARGET_DIR)/etc/init.d/S45ifplugd
        # don't use bash for init script
        $(SED) 's^/bin/bash^/bin/sh^g' $(TARGET_DIR)/etc/init.d/S45ifplugd
+       touch $@
\ No newline at end of file