python-gunicorn: new package
authorLionel Flandrin <lionel@svkt.org>
Mon, 30 Jan 2017 14:11:17 +0000 (15:11 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 5 Feb 2017 21:51:45 +0000 (22:51 +0100)
Gunicorn ‘Green Unicorn’ is a Python WSGI HTTP Server for UNIX. It’s a
pre-fork worker model ported from Ruby’s Unicorn project. The Gunicorn
server is broadly compatible with various web frameworks, simply
implemented, light on server resource usage, and fairly speedy.

Signed-off-by: Lionel Flandrin <lionel@svkt.org>
Reviewed-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/python-gunicorn/Config.in [new file with mode: 0644]
package/python-gunicorn/python-gunicorn.hash [new file with mode: 0644]
package/python-gunicorn/python-gunicorn.mk [new file with mode: 0644]

index d1c517aa5ccf771c6aa125b3c720fdc135e78e7a..cb6c12e6ab40dec856f19718156e767da6b092b5 100644 (file)
@@ -697,6 +697,7 @@ menu "External python modules"
        source "package/python-flup/Config.in"
        source "package/python-futures/Config.in"
        source "package/python-gobject/Config.in"
+       source "package/python-gunicorn/Config.in"
        source "package/python-html5lib/Config.in"
        source "package/python-httplib2/Config.in"
        source "package/python-humanize/Config.in"
diff --git a/package/python-gunicorn/Config.in b/package/python-gunicorn/Config.in
new file mode 100644 (file)
index 0000000..79cda3e
--- /dev/null
@@ -0,0 +1,13 @@
+config BR2_PACKAGE_PYTHON_GUNICORN
+       bool "python-gunicorn"
+       select BR2_PACKAGE_PYTHON_SETUPTOOLS # runtime
+       select BR2_PACKAGE_PYTHON_SSL if BR2_PACKAGE_PYTHON # runtime
+       select BR2_PACKAGE_PYTHON3_SSL if BR2_PACKAGE_PYTHON3 # runtime
+       help
+         Gunicorn ‘Green Unicorn’ is a Python WSGI HTTP Server for
+         UNIX. It’s a pre-fork worker model ported from Ruby’s
+         Unicorn project. The Gunicorn server is broadly compatible
+         with various web frameworks, simply implemented, light on
+         server resource usage, and fairly speedy.
+
+         http://gunicorn.org/
diff --git a/package/python-gunicorn/python-gunicorn.hash b/package/python-gunicorn/python-gunicorn.hash
new file mode 100644 (file)
index 0000000..a282bc9
--- /dev/null
@@ -0,0 +1,3 @@
+# md5 from https://pypi.python.org/pypi/gunicorn/json, sha256 locally computed
+md5    338e5e8a83ea0f0625f768dba4597530  gunicorn-19.6.0.tar.gz
+sha256 813f6916d18a4c8e90efde72f419308b357692f81333cb1125f80013d22fb618  gunicorn-19.6.0.tar.gz
diff --git a/package/python-gunicorn/python-gunicorn.mk b/package/python-gunicorn/python-gunicorn.mk
new file mode 100644 (file)
index 0000000..426e809
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-gunicorn
+#
+################################################################################
+
+PYTHON_GUNICORN_VERSION = 19.6.0
+PYTHON_GUNICORN_SOURCE = gunicorn-$(PYTHON_GUNICORN_VERSION).tar.gz
+PYTHON_GUNICORN_SITE = https://pypi.python.org/packages/84/ce/7ea5396efad1cef682bbc4068e72a0276341d9d9d0f501da609fab9fcb80
+PYTHON_GUNICORN_SETUP_TYPE = setuptools
+PYTHON_GUNICORN_LICENSE = MIT
+PYTHON_GUNICORN_LICENSE_FILES = LICENSE
+
+$(eval $(python-package))