package infra: drop non-lfs support
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 30 Mar 2015 21:07:25 +0000 (18:07 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 1 Apr 2015 20:43:01 +0000 (22:43 +0200)
Now that largefile is mandatory remove support for non-lfs
tweaks/variables in the package infra and the gcc build.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Makefile.in
package/gcc/gcc-final/gcc-final.mk
package/pkg-autotools.mk

index 803b162a74961b9a593a11d886b18f8452456320..fc57427e23339cfb23c2c6294150d0ecf11faa1c 100644 (file)
@@ -136,10 +136,7 @@ ifeq ($(BR2_DEBUG_3),y)
 TARGET_DEBUGGING = -g3
 endif
 
-ifeq ($(BR2_LARGEFILE),y)
 TARGET_CPPFLAGS += -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64
-endif
-
 TARGET_CFLAGS = $(TARGET_CPPFLAGS) $(TARGET_ABI) $(TARGET_OPTIMIZATION) $(TARGET_DEBUGGING)
 TARGET_CXXFLAGS = $(TARGET_CFLAGS)
 TARGET_LDFLAGS = $(call qstrip,$(BR2_TARGET_LDFLAGS))
@@ -373,10 +370,6 @@ else
 DISABLE_NLS :=--disable-nls
 endif
 
-ifneq ($(BR2_LARGEFILE),y)
-DISABLE_LARGEFILE = --disable-largefile
-endif
-
 ifeq ($(BR2_INET_IPV6),y)
 DISABLE_IPV6 = --enable-ipv6
 else
index c014bc5a20fd7d2df649cb3ded88f0f7955c6969..d76eb313827b5b7126036dfd0cee0d1a9b7148a1 100644 (file)
@@ -49,7 +49,6 @@ GCC_FINAL_CROSS_LANGUAGES = $(subst $(space),$(comma),$(GCC_FINAL_CROSS_LANGUAGE
 HOST_GCC_FINAL_CONF_OPTS = \
        $(HOST_GCC_COMMON_CONF_OPTS) \
        --enable-languages=$(GCC_FINAL_CROSS_LANGUAGES) \
-       $(DISABLE_LARGEFILE) \
        --enable-poison-system-directories \
        --with-build-time-tools=$(HOST_DIR)/usr/$(GNU_TARGET_NAME)/bin
 
index d2f15fa33e0dc15a3069f6176767a096658ffba4..2ecf7d82733eb108269fb81c41091382cdc25f35 100644 (file)
@@ -201,7 +201,6 @@ define $(2)_CONFIGURE_CMDS
                --with-fop=no \
                --disable-dependency-tracking \
                $$(DISABLE_NLS) \
-               $$(DISABLE_LARGEFILE) \
                $$(DISABLE_IPV6) \
                $$(ENABLE_DEBUG) \
                $$(SHARED_STATIC_LIBS_OPTS) \