package/suricata: needs autoreconf
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Tue, 28 May 2019 17:15:30 +0000 (19:15 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 28 May 2019 20:36:59 +0000 (22:36 +0200)
Commit 1ce2db1090c494f57019af4f29691e0f86b48330 was the second patch of
a third patch serie, it was applied without the first one so
AUTORECONF=YES was missing and patch number was wrong. Fix these two
errors.

Fixes:
 - http://autobuild.buildroot.org/results/a26d3493399c43faa37d2d67d772e0833971a9de

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/suricata/0001-configure.ac-fix-static-build-with-pcap.patch [new file with mode: 0644]
package/suricata/0002-configure.ac-fix-static-build-with-pcap.patch [deleted file]
package/suricata/suricata.mk

diff --git a/package/suricata/0001-configure.ac-fix-static-build-with-pcap.patch b/package/suricata/0001-configure.ac-fix-static-build-with-pcap.patch
new file mode 100644 (file)
index 0000000..3312550
--- /dev/null
@@ -0,0 +1,29 @@
+From 2660123b0c16d7f6a49747711be676c4119561c9 Mon Sep 17 00:00:00 2001
+From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+Date: Wed, 24 Apr 2019 20:35:20 +0200
+Subject: [PATCH] configure.ac: fix static build with pcap
+
+pcap can depends on nl-3 so use pkg-config to find these dependencies
+otherwise all AC_CHECK_LIB calls will fail when building statically
+
+Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+[Upstream status: not sent yet]
+---
+ configure.ac | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/configure.ac b/configure.ac
+index ee59c9d8e..5ec341231 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1331,6 +1331,7 @@
+     AC_CHECK_HEADERS([pcap.h pcap/pcap.h pcap/bpf.h])
+     LIBPCAP=""
++    PKG_CHECK_MODULES([PCAP],libpcap,[CPPFLAGS="${CPPFLAGS} ${PCAP_CFLAGS}" LIBS="${LIBS} ${PCAP_LIBS}"],[])
+     AC_CHECK_LIB(${PCAP_LIB_NAME}, pcap_open_live,, LIBPCAP="no")
+     if test "$LIBPCAP" = "no"; then
+         echo
+-- 
+2.20.1
+
diff --git a/package/suricata/0002-configure.ac-fix-static-build-with-pcap.patch b/package/suricata/0002-configure.ac-fix-static-build-with-pcap.patch
deleted file mode 100644 (file)
index 3312550..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
-From 2660123b0c16d7f6a49747711be676c4119561c9 Mon Sep 17 00:00:00 2001
-From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
-Date: Wed, 24 Apr 2019 20:35:20 +0200
-Subject: [PATCH] configure.ac: fix static build with pcap
-
-pcap can depends on nl-3 so use pkg-config to find these dependencies
-otherwise all AC_CHECK_LIB calls will fail when building statically
-
-Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
-[Upstream status: not sent yet]
----
- configure.ac | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/configure.ac b/configure.ac
-index ee59c9d8e..5ec341231 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -1331,6 +1331,7 @@
-     AC_CHECK_HEADERS([pcap.h pcap/pcap.h pcap/bpf.h])
-     LIBPCAP=""
-+    PKG_CHECK_MODULES([PCAP],libpcap,[CPPFLAGS="${CPPFLAGS} ${PCAP_CFLAGS}" LIBS="${LIBS} ${PCAP_LIBS}"],[])
-     AC_CHECK_LIB(${PCAP_LIB_NAME}, pcap_open_live,, LIBPCAP="no")
-     if test "$LIBPCAP" = "no"; then
-         echo
--- 
-2.20.1
-
index e5884cdfe4160ce0a3b5c3b3c6041feeb3d60f46..0491fad6d526f35c852e4898d23d952726bdbce1 100644 (file)
@@ -8,6 +8,8 @@ SURICATA_VERSION = 4.1.3
 SURICATA_SITE = https://www.openinfosecfoundation.org/download
 SURICATA_LICENSE = GPL-2.0
 SURICATA_LICENSE_FILES = COPYING LICENSE
+# We're patching configure.ac
+SURICATA_AUTORECONF = YES
 
 SURICATA_DEPENDENCIES = \
        host-pkgconf \