nmap: use system liblinear
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Tue, 9 Oct 2018 17:22:17 +0000 (19:22 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 11 Oct 2018 08:06:51 +0000 (10:06 +0200)
Use system liblinear instead of using included liblinear.
liblinear in buildroot is at version 2.20 released on December 2017
whereas liblinear in nmap has not been updated since 7 years (except for
liblinear.vcxproj which has been updated 2 years ago)

Do not use --with-liblinear option as otherwise nmap will forget to add
-llinear to LIBS due to the following line in configure.ac:

if test $have_liblinear != yes; then
  AC_CHECK_HEADERS([linear.h],
    AC_CHECK_LIB(linear, predict, [have_liblinear=yes; LIBLINEAR_LIBS="-llinear"; break],, [-lm])
)

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/nmap/Config.in
package/nmap/nmap.mk

index c1aafeceb9c555fc278afcc2622c21bb6278d160..51dd3423eaed83f63b377ff81fde220fbbdaa83b 100644 (file)
@@ -3,6 +3,7 @@ config BR2_PACKAGE_NMAP
        depends on BR2_INSTALL_LIBSTDCPP
        depends on BR2_USE_MMU # fork()
        depends on BR2_TOOLCHAIN_HAS_THREADS
+       select BR2_PACKAGE_LIBLINEAR
        select BR2_PACKAGE_LIBPCAP
        select BR2_PACKAGE_NMAP_NMAP \
               if !BR2_PACKAGE_NMAP_NCAT && !BR2_PACKAGE_NMAP_NPING && !BR2_PACKAGE_NMAP_NDIFF
index 8809d4c037f43b9319452ff53af79bd280df8d15..761df3ffa8295eb35fec3d1d1b1527d674ccf83b 100644 (file)
@@ -7,9 +7,9 @@
 NMAP_VERSION = 7.70
 NMAP_SITE = https://nmap.org/dist
 NMAP_SOURCE = nmap-$(NMAP_VERSION).tar.bz2
-NMAP_DEPENDENCIES = libpcap
+NMAP_DEPENDENCIES = liblinear libpcap
 NMAP_CONF_OPTS = --without-liblua --without-zenmap \
-       --with-libdnet=included --with-liblinear=included
+       --with-libdnet=included
 NMAP_LICENSE = nmap license
 NMAP_LICENSE_FILES = COPYING