gnupg2: Needs a suitable iconv implementation
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>
Thu, 14 Aug 2014 12:16:12 +0000 (13:16 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 15 Aug 2014 20:30:36 +0000 (22:30 +0200)
gnupg2 needs a toolchain with locale support or a package which provides
a suitable iconv implementation (libiconv). Otherwise it will fail at
the configure phase with an error like this one:

*** It is now required to build with support for iconv
*** Please install a suitable iconv implementation.

Fixes:
  http://autobuild.buildroot.net/results/8c9/8c93c28533dfebffa8b2e34b1421d3fa3cdeb278/

Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Reviewed-by: Markos Chandras <Markos.Chandras@imgtec.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gnupg2/Config.in
package/gnupg2/gnupg2.mk

index be97a2013213522c573028f4da78152ad0c25228..d24eaaee1f8445425ea85f19675241ce3673f6c6 100644 (file)
@@ -7,6 +7,7 @@ config BR2_PACKAGE_GNUPG2
        select BR2_PACKAGE_LIBKSBA
        select BR2_PACKAGE_LIBPTHSEM
        select BR2_PACKAGE_LIBPTHSEM_COMPAT
+       select BR2_PACKAGE_LIBICONV if !BR2_ENABLE_LOCALE
        depends on BR2_USE_MMU # libassuan
        help
          GnuPG is the GNU project's complete and free implementation
index 9502a8241b055eeecd1083015403b7edb55f4e11..5e108d9312fea7295725bbbe14cc8d6f34179847 100644 (file)
@@ -9,7 +9,8 @@ GNUPG2_SOURCE = gnupg-$(GNUPG2_VERSION).tar.bz2
 GNUPG2_SITE = ftp://ftp.gnupg.org/gcrypt/gnupg
 GNUPG2_LICENSE = GPLv3+
 GNUPG2_LICENSE_FILES = COPYING
-GNUPG2_DEPENDENCIES = zlib libgpg-error libgcrypt libassuan libksba libpthsem
+GNUPG2_DEPENDENCIES = zlib libgpg-error libgcrypt libassuan libksba libpthsem \
+       $(if $(BR2_PACKAGE_LIBICONV),libiconv)
 GNUPG2_CONF_OPT = \
        --disable-rpath --disable-regex --disable-doc \
        --with-libgpg-error-prefix=$(STAGING_DIR)/usr \