rsync: make acl support non-random
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 31 Mar 2014 17:28:10 +0000 (14:28 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 3 Apr 2014 18:18:11 +0000 (20:18 +0200)
If acl is selected then add it to dependencies so it can be used by
rsync in a predictable fashion.
Extended attributes are handled directly via linux, there's no need
for the xattr package/library.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/rsync/rsync.mk

index 35f128c97e592a2ffa71564f599d6181d29a20ef..d0ceaa99ac00f79e59aa317e3a241d476ca11c16 100644 (file)
@@ -14,4 +14,10 @@ RSYNC_CONF_OPT = \
        --with-included-zlib=no \
        --with-included-popt=no
 
+ifeq ($(BR2_PACKAGE_ACL),y)
+       RSYNC_DEPENDENCIES += acl
+else
+       RSYNC_CONF_OPT += --disable-acl-support
+endif
+
 $(eval $(autotools-package))