lbreakout2: use the new gettext logic
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 3 Jul 2017 20:51:10 +0000 (22:51 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Jul 2017 23:27:26 +0000 (01:27 +0200)
This commit switches to use the new gettext logic, which involves:

 - using TARGET_NLS_DEPENDENCIES instead of hand-encoded dependencies
   on gettext/host-gettext

 - using TARGET_NLS_LIBS to force linking against libintl

 - dropping BR2_PACKAGE_GETTEXT selection

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/lbreakout2/Config.in
package/lbreakout2/lbreakout2.mk

index 221c9e2c5b677286e477d905d61d7bb22288e3e6..6788aca8211e362b142d62097ba34769bd1d15e0 100644 (file)
@@ -2,7 +2,6 @@ config BR2_PACKAGE_LBREAKOUT2
        bool "LBreakout2"
        select BR2_PACKAGE_SDL
        select BR2_PACKAGE_LIBPNG
-       select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT_IF_LOCALE
        help
          LBreakout2 is the successor to LBreakout, a breakout-style arcade
          game in the manner of Arkanoid. Requires SDL, libpng, and
index 017d56244e0d18576fa74095f4c4a626339d04b0..274c5346605e93db859d7272994b6a23a0bf9a80 100644 (file)
@@ -10,15 +10,11 @@ LBREAKOUT2_SITE = http://downloads.sourceforge.net/lgames/lbreakout2/$(LBREAKOUT
 LBREAKOUT2_LICENSE = GPL-2.0+
 LBREAKOUT2_LICENSE_FILES = COPYING
 
-LBREAKOUT2_DEPENDENCIES = sdl libpng
+LBREAKOUT2_DEPENDENCIES = sdl libpng $(TARGET_NLS_DEPENDENCIES)
 
 LBREAKOUT2_CONF_ENV = \
-       SDL_CONFIG="$(STAGING_DIR)/usr/bin/sdl-config"
-
-ifeq ($(BR2_NEEDS_GETTEXT_IF_LOCALE),y)
-LBREAKOUT2_DEPENDENCIES += gettext
-LBREAKOUT2_CONF_ENV += LIBS=-lintl
-endif
+       SDL_CONFIG="$(STAGING_DIR)/usr/bin/sdl-config" \
+       LIBS=$(TARGET_NLS_LIBS)
 
 ifeq ($(BR2_PACKAGE_LBREAKOUT2_AUDIO),y)
 LBREAKOUT2_DEPENDENCIES += sdl_mixer