package/dvb-apps: rely on dtv-scan-tables to provide transponder data
authorYann E. MORIN <yann.morin.1998@free.fr>
Fri, 28 Mar 2014 00:00:21 +0000 (01:00 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 29 Mar 2014 17:29:11 +0000 (18:29 +0100)
This is a transitioning solution before switching packages that need the
transponders data, to use dtv-scan-tables instead of dvb-apps.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/dtv-scan-tables/Config.in
package/dvb-apps/Config.in
package/dvb-apps/dvb-apps.mk

index 05a3b1c187274277c36d2b69cec319640e9f0ddc..e102ca730c9b5ce7d92bde8995cfa582b0500f72 100644 (file)
@@ -1,7 +1,5 @@
 config BR2_PACKAGE_DTV_SCAN_TABLES
        bool "dtv-scan-tables"
-       # dvb-apps installs its own set of transponder data
-       depends on !BR2_PACKAGE_DVB_APPS
        help
          The Digital TV scan tables.
 
index ea0a12ff8123bfd001a938d1467895e0b0a2a6b5..76b33aabb717110caf69c5a45f0891c8391f0c80 100644 (file)
@@ -1,5 +1,6 @@
 config BR2_PACKAGE_DVB_APPS
        bool "dvb-apps (transponders data)"
+       select BR2_PACKAGE_DTV_SCAN_TABLES
        help
          Install the DVB-C, DVB-S, DVB-T and ATSC transponders data.
 
index e351258763d3ad247180145310c81826a1291abd..5f576e079fb89046ee0fa62bf1ab768db65d4420 100644 (file)
@@ -8,21 +8,13 @@ DVB_APPS_VERSION        = be76da69f250
 DVB_APPS_SITE           = http://linuxtv.org/hg/dvb-apps
 DVB_APPS_SITE_METHOD    = hg
 
-# We just install the transponders data. As this is not a 'work' as per
-# traditional copyright, but just a collection of 'facts', there's probably
-# no license to apply to these data files.
-# To be noted however, is that the dvb-apps package bundles a copy of the
-# GPLv2 and a copy of the LGPLv2.1, and that some of the source files refer
-# to either the GPLv2+ or the LGPLv2.1+.
-# But since we do not use any of those source files, their license do not
-# apply to us.
-DVB_APPS_LICENSE        = unknown (probably public domain)
+DVB_APPS_DEPENDENCIES   = dtv-scan-tables
 
 ifeq ($(BR2_PACKAGE_DVB_APPS_UTILS),y)
 # Utilitiess are selected, build and install everything
 
-DVB_APPS_LICENSE       += GPLv2 GPLv2+ LGPLv2.1+
-DVB_APPS_LICENSE_FILES += COPYING COPYING.LGPL
+DVB_APPS_LICENSE        = GPLv2 GPLv2+ LGPLv2.1+
+DVB_APPS_LICENSE_FILES  = COPYING COPYING.LGPL
 
 DVB_APPS_LDFLAGS = $(TARGET_LDFLAGS)
 
@@ -47,13 +39,8 @@ define DVB_APPS_INSTALL_TARGET_CMDS
 endef
 
 else
-# Utilities are not selected, just install the scan files
-define DVB_APPS_INSTALL_TARGET_CMDS
-       for i in atsc dvb-c dvb-s dvb-t; do \
-               mkdir -p $(TARGET_DIR)/usr/share/dvb/$$i; \
-               $(INSTALL) $(@D)/util/scan/$$i/* $(TARGET_DIR)/usr/share/dvb/$$i; \
-       done
-endef
+# We do not really install anything, so there's no license
+DVB_APPS_LICENSE        = none
 endif
 
 $(eval $(generic-package))