package/qt5/qt5base: exclude OpenSSL functionality for Qt 5.6.x
authorJames Grant <james.grant@jci.com>
Fri, 1 Mar 2019 02:17:12 +0000 (15:17 +1300)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 1 Mar 2019 09:13:14 +0000 (10:13 +0100)
No patch back-porting OpenSSL 1.1.x support to Qt 5.6.x is available.

https://development.qt-project.narkive.com/RW4wxYXY/openssl-1-1-x-support-on-qt-5-6-5-9

Signed-off-by: James Grant <james.grant@jci.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/qt5/qt5base/qt5base.mk

index e71878a487b105b5eedd164b6aae0c876be9edbe..a5ce583327ce2667779711ffc24da161879595c6 100644 (file)
@@ -188,8 +188,13 @@ else
 QT5BASE_CONFIGURE_OPTS += -no-eglfs
 endif
 
+ifeq ($(BR2_PACKAGE_QT5_VERSION_5_6),y)
+# No OpenSSL 1.1.x support in Qt 5.6.x
+QT5BASE_CONFIGURE_OPTS += -no-openssl
+else
 QT5BASE_CONFIGURE_OPTS += $(if $(BR2_PACKAGE_OPENSSL),-openssl,-no-openssl)
 QT5BASE_DEPENDENCIES   += $(if $(BR2_PACKAGE_OPENSSL),openssl)
+endif
 
 QT5BASE_CONFIGURE_OPTS += $(if $(BR2_PACKAGE_QT5BASE_FONTCONFIG),-fontconfig,-no-fontconfig)
 QT5BASE_DEPENDENCIES   += $(if $(BR2_PACKAGE_QT5BASE_FONTCONFIG),fontconfig)