dawgdic: new package
authorJonathan Ben Avraham <yba@tkos.co.il>
Mon, 3 Aug 2015 09:16:03 +0000 (12:16 +0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Aug 2015 09:15:37 +0000 (11:15 +0200)
The dawgdic package provides object files and utilities for building
and accessing directed acyclical word graph (DAWG) dictionaries.

This version of the patch uses the updated GitHub dawgdic repo instead
of the Google Code repo used in the previous version of this patch.

[Thomas:
  - use the github macro for <pkg>_SITE
  - remove <pkg>_SITE_METHOD, useless once you use the github macro
    for <pkg>_SITE
  - fix the license, it is BSD-3c and not GPLv3
  - remove commented <pkg>_SITE in the .mk file
  - add missing dependency on C++.]

Signed-off-by: Jonathan Ben Avraham <yba@tkos.co.il>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/dawgdic/Config.in [new file with mode: 0644]
package/dawgdic/dawgdic.mk [new file with mode: 0644]

index 43c58caa0da947cce10bf28a0f55470fd156d1bc..47d14d7d31189ff41dc6d4227f26583283b80030 100644 (file)
@@ -1045,6 +1045,7 @@ menu "Other"
        source "package/clapack/Config.in"
        source "package/classpath/Config.in"
        source "package/cppcms/Config.in"
+       source "package/dawgdic/Config.in"
        source "package/ding-libs/Config.in"
        source "package/eigen/Config.in"
        source "package/elfutils/Config.in"
diff --git a/package/dawgdic/Config.in b/package/dawgdic/Config.in
new file mode 100644 (file)
index 0000000..ce0b466
--- /dev/null
@@ -0,0 +1,17 @@
+config BR2_PACKAGE_DAWGDIC
+       bool "dawgdic"
+       depends on BR2_INSTALL_LIBSTDCPP
+       help
+         dawgdic provides a library for building and accessing
+         dictionaries implemented with directed acyclic word graphs
+         (DAWG). A dawg is constructed by minimizing a trie as a
+         deterministic finite automaton (DFA), and thus the dawg has
+         an advantage in memory usage. In addition, dawgdic uses a
+         double-array as a base data structure, so its retrieval
+         speed is as fast as that of Darts, a library for building
+         and accessing double-array tries.
+
+         https://github.com/stil/dawgdic
+
+comment "dawgdic needs a toolchain w/ C++"
+       depends on !BR2_INSTALL_LIBSTDCPP
diff --git a/package/dawgdic/dawgdic.mk b/package/dawgdic/dawgdic.mk
new file mode 100644 (file)
index 0000000..2f0a53b
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# dawgdic
+#
+################################################################################
+
+DAWGDIC_VERSION = 16ac537ba9883ff01b63b6d1fdc3072150c68fee
+DAWGDIC_SITE = $(call github,stil,dawgdic,$(DAWGDIC_VERSION))
+DAWGDIC_LICENSE = BSD-3c
+DAWGDIC_LICENSE_FILES = COPYING
+DAWGDIC_AUTORECONF = YES
+DAWGDIC_INSTALL_STAGING = YES
+
+$(eval $(autotools-package))