package/coreutils: ensure configure isn't considered out-of-date
authorPeter Korsgaard <jacmet@sunsite.dk>
Tue, 1 Dec 2009 09:14:26 +0000 (10:14 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 1 Dec 2009 09:22:12 +0000 (10:22 +0100)
We were patching m4/rename.m4 to workaround an upstream issue, but this
triggers a auto* rebuild and a configure rerun when we build coreutils
using whatever auto* versions the user has installed.

Doing a manual autoreconf run after patching is unfortunately not an
option as the coreutils configure.ac isn't compatible with the autotools
version we have in BR.

Instead, simply cheat by patching configure as well and setting the
timestamp of m4/rename.m4 sufficiently far back to ensure make doesn't
consider ./configure out of date.

Long term we should convert coreutils to Makefile.autotools.in format,
but this is good enought for 2009.11.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/coreutils/coreutils-7.4-rename-m4-fix.patch
package/coreutils/coreutils.mk

diff --git a/CHANGES b/CHANGES
index 5cc8771d19c76d03e997118556f6778f69d74c89..145282362b5a7cf550276f100f589f94acb001d5 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -2,7 +2,8 @@
 
        Additional fixes and cleanups.
 
-       Updated/fixed packages: alsamixergui, fltk, microperl, ncurses, vim
+       Updated/fixed packages: alsamixergui, coreutils, fltk, microperl,
+       ncurses, vim
 
        Issues resolved (http://bugs.uclibc.org):
 
index f869f439cabae0b397f234525c30fc7f8ee36866..817720066b13417a0f4ede572899956bc8e66fac 100644 (file)
@@ -23,3 +23,22 @@ Index: coreutils-7.4/m4/rename.m4
        AC_DEFINE([RENAME_DEST_EXISTS_BUG], [1],
        [Define if rename does not work when the destination file exists,
         as on Windows.])
+Index: coreutils-7.4/configure
+===================================================================
+--- coreutils-7.4.orig/configure
++++ coreutils-7.4/configure
+@@ -28698,12 +28698,12 @@ $as_echo "$gl_cv_func_rename_dest_exists
+ $as_echo "#define rename rpl_rename" >>confdefs.h
+-    if test $gl_cv_func_rename_trailing_slash_bug; then
++    if test $gl_cv_func_rename_trailing_slash_bug = yes; then
+ $as_echo "#define RENAME_TRAILING_SLASH_BUG 1" >>confdefs.h
+     fi
+-    if test $gl_cv_func_rename_dest_exists_bug; then
++    if test $gl_cv_func_rename_dest_exists_bug = yes; then
+ $as_echo "#define RENAME_DEST_EXISTS_BUG 1" >>confdefs.h
index d2a3586e4ce12f12c7c05497ec3ee168434ac6ec..0dcb62b675ec7cecf044a0758f03a75b1ab92090 100644 (file)
@@ -23,6 +23,9 @@ $(COREUTILS_DIR)/.unpacked: $(DL_DIR)/$(COREUTILS_SOURCE)
        $(COREUTILS_CAT) $(DL_DIR)/$(COREUTILS_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
        toolchain/patch-kernel.sh $(COREUTILS_DIR) package/coreutils/ coreutils\*.patch
        $(CONFIG_UPDATE) $(COREUTILS_DIR)/build-aux
+       # ensure rename.m4 file is older than configure / aclocal.m4 so
+       # auto* isn't rerun
+       touch -d '1979-01-01' $(@D)/m4/rename.m4
        touch $@
 
 $(COREUTILS_DIR)/.configured: $(COREUTILS_DIR)/.unpacked