Minor clean-up
authorThiago A. Corrêa <thiago.correa@gmail.com>
Fri, 4 Jul 2008 02:12:21 +0000 (02:12 -0000)
committerThiago A. Corrêa <thiago.correa@gmail.com>
Fri, 4 Jul 2008 02:12:21 +0000 (02:12 -0000)
package/pkgconfig/pkgconfig.mk

index 0d41dae0debaaca21241bf1d1014e0e41f09e440..6ecb8f91fdf1d09c9c972b25f9812a99b8574895 100644 (file)
@@ -19,7 +19,7 @@ pkgconfig-source: $(DL_DIR)/$(PKGCONFIG_SOURCE)
 $(PKGCONFIG_DIR)/.unpacked: $(DL_DIR)/$(PKGCONFIG_SOURCE)
        $(PKGCONFIG_CAT) $(DL_DIR)/$(PKGCONFIG_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
        toolchain/patch-kernel.sh $(PKGCONFIG_DIR) package/pkgconfig/ \*.patch
-       touch $(PKGCONFIG_DIR)/.unpacked
+       touch $@
 
 $(PKGCONFIG_DIR)/.configured: $(PKGCONFIG_DIR)/.unpacked
        (cd $(PKGCONFIG_DIR); rm -rf config.cache; \
@@ -30,7 +30,7 @@ $(PKGCONFIG_DIR)/.configured: $(PKGCONFIG_DIR)/.unpacked
                $(DISABLE_NLS) \
                $(DISABLE_LARGEFILE) \
        )
-       touch $(PKGCONFIG_DIR)/.configured
+       touch $@
 
 $(PKGCONFIG_DIR)/$(PKGCONFIG_BINARY): $(PKGCONFIG_DIR)/.configured
        $(MAKE) -C $(PKGCONFIG_DIR)