gstreamer1: don't rely on a recent coreutils for relative symlink support
authorPeter Korsgaard <peter@korsgaard.com>
Tue, 2 Feb 2016 08:07:24 +0000 (09:07 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 2 Feb 2016 08:17:38 +0000 (09:17 +0100)
Fixes:
http://autobuild.buildroot.net/results/3ae/3ae368cfd0ecd7be4c7e864590ec5dbf79d576ac/
http://autobuild.buildroot.net/results/4c9/4c951f31984e0eff21fc165cb68065f527c237e6/

And many more.

The recent change to create the legacy gstconfig.h symlink using ln -srf
unfortunately breaks on older distributions as it was only added in
coreutils 8.16 (2012).

Instead, "manually" create the relative symlink.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/gstreamer1/gstreamer1/gstreamer1.mk

index 0eb46e8a1da99768cd9115ed2a220b507ee421ee..b78816012cdd11050b1e8870122865c4f6b7f3a6 100644 (file)
@@ -41,8 +41,8 @@ GSTREAMER1_DEPENDENCIES = libglib2 host-pkgconf host-bison host-flex
 # updated to look in the correct location.
 # Add a symlink to the legacy location
 define GSTREAMER1_LEGACY_CGSTCONFIG_H
-       ln -srf $(STAGING_DIR)/usr/lib/gstreamer-1.0/include/gst/gstconfig.h \
-              $(STAGING_DIR)/usr/include/gstreamer-1.0/gst/gstconfig.h
+       cd $(STAGING_DIR)/usr/include/gstreamer-1.0/gst && \
+               ln -sf ../../../lib/gstreamer-1.0/include/gst/gstconfig.h .
 endef
 GSTREAMER1_POST_INSTALL_STAGING_HOOKS += GSTREAMER1_LEGACY_CGSTCONFIG_H