pcmcia update
authorEric Andersen <andersen@codepoet.org>
Tue, 21 Jan 2003 06:41:00 +0000 (06:41 -0000)
committerEric Andersen <andersen@codepoet.org>
Tue, 21 Jan 2003 06:41:00 +0000 (06:41 -0000)
make/pcmcia.mk
sources/pcmcia.patch
sources/target_skeleton/etc/init.d/S30pcmcia [deleted file]

index e278ea64280a9a45f0034efa4e486fb6539e0d5c..51f634df3ca8906e25f8955d65724a5a21453368 100644 (file)
@@ -78,7 +78,7 @@ $(TARGET_DIR)/sbin/cardmgr: $(PCMCIA_DIR)/cardmgr/cardmgr
        rm -f $(TARGET_DIR)/usr/share/pnp.ids $(TARGET_DIR)/sbin/lspnp $(TARGET_DIR)/sbin/setpnp;
        rm -f $(TARGET_DIR)/sbin/pcinitrd
        rm -f $(TARGET_DIR)/sbin/probe
-       cp $(PCMCIA_DIR)/etc/rc.pcmcia $(TARGET_DIR)/etc/init.d/
+       cp $(PCMCIA_DIR)/etc/rc.pcmcia $(TARGET_DIR)/etc/init.d/S30pcmcia
        chmod -R u+w $(TARGET_DIR)/etc/pcmcia/*
 
 pcmcia: uclibc $(TARGET_DIR)/sbin/cardmgr
index 42a16175db0069eab2d63bd6fafefedbaa1c454f..38c517040b45c4c687bb8496f133ed01fc12d42f 100644 (file)
@@ -39,16 +39,3 @@ diff -urN pcmcia-cs-3.1.33.orig/etc/shared pcmcia-cs-3.1.33/etc/shared
  # Infrastructure network for older cards
  #module "ray_cs" opts "net_type=1 essid=ESSID1"
  # Infrastructure network for WebGear
---- pcmcia-cs-3.2.1/Configure.orig     Thu Aug  8 00:38:15 2002
-+++ pcmcia-cs-3.2.1/Configure  Tue Sep 10 05:41:24 2002
-@@ -669,6 +669,10 @@
-      >/dev/null 2>&1 ; then
-     CONFIG_IEEE1394=n
- fi
-+
-+# Hack to disable network stuff for the time being...
-+CONFIG_INET=n
-+
- printconfig
- echo ""
diff --git a/sources/target_skeleton/etc/init.d/S30pcmcia b/sources/target_skeleton/etc/init.d/S30pcmcia
deleted file mode 100755 (executable)
index a3906c3..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
-# Select the module that is correct for your hardware
-
-PCIC=yenta_socket
-#PCIC=i82365
-#PCIC=tcic
-#PCIC=sa1100_cs
-
-# Load up all the pcmcia modules
-/sbin/modprobe pcmcia_core
-/sbin/modprobe $PCIC
-/sbin/modprobe ds
-
-if [ $? != 0 ] ; then 
-    echo "pcmcia support not detected";
-    exit 0;
-fi
-
-/sbin/cardmgr -m /lib/modules
-
-exit 0;