erlang: add option to enable SMP support
authorFrank Hunleth <fhunleth@troodon-software.com>
Fri, 13 Dec 2013 14:56:11 +0000 (09:56 -0500)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 15 Dec 2013 08:47:37 +0000 (09:47 +0100)
Erlang builds two emulators depending on whether SMP is supported or
not. If it is known that the target does not support SMP, turning off
the SMP emulator saves compile time and reduces the size of the
installation.

Signed-off-by: Frank Hunleth <fhunleth@troodon-software.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/erlang/Config.in
package/erlang/erlang.mk

index 27206f30671c9f07aefae314dcc8c0b76bdb1bc4..2ee85155e4825d81d3f5e90fcefbbf731cf43fe7 100644 (file)
@@ -10,11 +10,23 @@ config BR2_PACKAGE_ERLANG
 
          http://www.erlang.org
 
+if BR2_PACKAGE_ERLANG
+
+config BR2_PACKAGE_ERLANG_SMP
+       bool "enable SMP support"
+       help
+         Erlang provides both a UP and an SMP emulator. The UP emulator
+         is always built, and this option enables compilation of the SMP
+         emulator. The choice of which emulator to use is made at runtime.
+         If you do not need SMP support, turning this option off reduces
+         compile time and the size of the Erlang installation.
+
 config BR2_PACKAGE_ERLANG_MEGACO
        bool "install megaco application"
-       depends on BR2_PACKAGE_ERLANG
        help
          The Megaco application is a framework for building applications
          on top of the Megaco/H.248 protocol. It is approximately 14MB in
          size so if you do not need it then it is recommended not to
          enable it.
+
+endif # BR2_PACKAGE_ERLANG
index 4a94af01abc37f4dbcfb490898dac851b3c1fc68..34d027b807cdd0f1da5883a163718df9f829459d 100644 (file)
@@ -43,6 +43,10 @@ ERLANG_CONF_OPT += --enable-shared-zlib
 ERLANG_DEPENDENCIES += zlib
 endif
 
+ifeq ($(BR2_PACKAGE_ERLANG_SMP),)
+ERLANG_CONF_OPT += --disable-smp-support
+endif
+
 # Remove source, example, gs and wx files from the target
 ERLANG_REMOVE_PACKAGES = gs wx