- see if the dir exists before trying to strip an empty list of files..
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Thu, 22 Mar 2007 17:21:18 +0000 (17:21 -0000)
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Thu, 22 Mar 2007 17:21:18 +0000 (17:21 -0000)
toolchain/gcc/gcc-uclibc-3.x.mk

index 257be158e21b863314c198763d4905738972364c..8e8267498e8e00ca962144ce3aa8d36f0df81720 100644 (file)
@@ -412,11 +412,11 @@ endif
        #
        # Ok... that's enough of that.
        #
-       -(cd $(TARGET_DIR)/bin; find -type f | xargs $(STRIP) > /dev/null 2>&1)
-       -(cd $(TARGET_DIR)/usr/bin; find -type f | xargs $(STRIP) > /dev/null 2>&1)
-       -(cd $(TARGET_DIR)/usr/$(GCC_LIB_SUBDIR); $(STRIP) cc1 cc1plus collect2 > /dev/null 2>&1)
-       -(cd $(TARGET_DIR)/usr/lib; $(STRIP) libstdc++.so.*.*.* > /dev/null 2>&1)
-       -(cd $(TARGET_DIR)/lib; $(STRIP) libgcc_s*.so.*.*.* > /dev/null 2>&1)
+       -(cd $(TARGET_DIR)/bin && find -type f | xargs $(STRIP) > /dev/null 2>&1)
+       -(cd $(TARGET_DIR)/usr/bin && find -type f | xargs $(STRIP) > /dev/null 2>&1)
+       -(cd $(TARGET_DIR)/usr/$(GCC_LIB_SUBDIR) && $(STRIP) cc1 cc1plus collect2 > /dev/null 2>&1)
+       -(cd $(TARGET_DIR)/usr/lib && $(STRIP) libstdc++.so.*.*.* > /dev/null 2>&1)
+       -(cd $(TARGET_DIR)/lib && $(STRIP) libgcc_s*.so.*.*.* > /dev/null 2>&1)
        #
        rm -f $(TARGET_DIR)/usr/lib/*.la*
        #rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/info \