Add the linux test project test suite. The 'make install' step is currently
authorEric Andersen <andersen@codepoet.org>
Mon, 6 Oct 2003 08:06:02 +0000 (08:06 -0000)
committerEric Andersen <andersen@codepoet.org>
Mon, 6 Oct 2003 08:06:02 +0000 (08:06 -0000)
broken, since I've not worked out how I want to handle that step (it wants to
run as root).

make/ltp-testsuite.mk [new file with mode: 0644]
sources/ltp-testsuite.patch [new file with mode: 0644]

diff --git a/make/ltp-testsuite.mk b/make/ltp-testsuite.mk
new file mode 100644 (file)
index 0000000..0b96b68
--- /dev/null
@@ -0,0 +1,39 @@
+#############################################################
+#
+# ltp-testsuite
+#
+#############################################################
+LTP_TESTSUITE_SOURCE:=ltp-full-20031002.tgz
+LTP_TESTSUITE_SITE:=http://aleron.dl.sourceforge.net/sourceforge/ltp
+LTP_TESTSUITE_CAT:=zcat
+LTP_TESTSUITE_DIR:=$(BUILD_DIR)/ltp-full-20031002
+LTP_TESTSUITE_PATCH:=$(SOURCE_DIR)/ltp-testsuite.patch
+
+
+$(DL_DIR)/$(LTP_TESTSUITE_SOURCE):
+        $(WGET) -P $(DL_DIR) $(LTP_TESTSUITE_SITE)/$(LTP_TESTSUITE_SOURCE)
+
+ltp-testsuite-source: $(DL_DIR)/$(LTP_TESTSUITE_SOURCE)
+
+$(LTP_TESTSUITE_DIR)/.unpacked: $(DL_DIR)/$(LTP_TESTSUITE_SOURCE)
+       $(LTP_TESTSUITE_CAT) $(DL_DIR)/$(LTP_TESTSUITE_SOURCE) | tar -C $(BUILD_DIR) -xvf -
+       cat $(LTP_TESTSUITE_PATCH) | patch -p1 -d $(LTP_TESTSUITE_DIR)
+       touch $(LTP_TESTSUITE_DIR)/.unpacked
+
+$(LTP_TESTSUITE_DIR)/ltp-testsuite: $(LTP_TESTSUITE_DIR)/.unpacked
+       $(MAKE) $(TARGET_CONFIGURE_OPTS) CROSS_COMPILER=$(TARGET_CROSS) \
+               -C $(LTP_TESTSUITE_DIR)
+
+$(TARGET_DIR)/usr/bin/ltp-testsuite: $(LTP_TESTSUITE_DIR)/ltp-testsuite
+       $(MAKE) $(TARGET_CONFIGURE_OPTS) CROSS_COMPILER=$(TARGET_CROSS) \
+               -C $(LTP_TESTSUITE_DIR) install
+
+ltp-testsuite: uclibc $(TARGET_DIR)/usr/bin/ltp-testsuite 
+
+ltp-testsuite-clean: 
+       $(MAKE) -C $(LTP_TESTSUITE_DIR) clean
+
+ltp-testsuite-dirclean: 
+       rm -rf $(LTP_TESTSUITE_DIR) 
+
+
diff --git a/sources/ltp-testsuite.patch b/sources/ltp-testsuite.patch
new file mode 100644 (file)
index 0000000..6890375
--- /dev/null
@@ -0,0 +1,55 @@
+--- ltp-full-20031002/testcases/kernel/syscalls/fmtmsg/Makefile.orig   2003-10-02 19:18:10.000000000 -0600
++++ ltp-full-20031002/testcases/kernel/syscalls/fmtmsg/Makefile        2003-10-02 19:18:32.000000000 -0600
+@@ -24,7 +24,7 @@
+ LOADLIBES+=   -L../../../../lib -lltp
+ SRCS=$(wildcard *.c)
+-TARGETS=$(patsubst %.c,%,$(SRCS))
++TARGETS=#$(patsubst %.c,%,$(SRCS))
+ all: $(TARGETS)
+--- ltp-full-20031002/testcases/kernel/syscalls/mallopt/Makefile.orig  2003-10-02 19:20:52.000000000 -0600
++++ ltp-full-20031002/testcases/kernel/syscalls/mallopt/Makefile       2003-10-02 19:21:07.000000000 -0600
+@@ -23,7 +23,7 @@
+ LOADLIBES+=   -L../../../../lib -lltp 
+ SRCS=$(wildcard *.c)
+-TARGETS=$(patsubst %.c,%,$(SRCS))
++TARGETS=#$(patsubst %.c,%,$(SRCS))
+ all: $(TARGETS)
+--- ltp-full-20031002/testcases/kernel/syscalls/profil/Makefile.orig   2003-10-02 19:27:53.000000000 -0600
++++ ltp-full-20031002/testcases/kernel/syscalls/profil/Makefile        2003-10-02 19:28:02.000000000 -0600
+@@ -23,7 +23,7 @@
+ LOADLIBES+=   -L../../../../lib -lltp 
+ SRCS=$(wildcard *.c)
+-TARGETS=$(patsubst %.c,%,$(SRCS))
++TARGETS=#$(patsubst %.c,%,$(SRCS))
+ all: $(TARGETS)
+--- ltp-full-20031002/testcases/network/rpc/rpc01/Makefile.orig        2003-10-02 19:36:51.000000000 -0600
++++ ltp-full-20031002/testcases/network/rpc/rpc01/Makefile     2003-10-02 19:37:03.000000000 -0600
+@@ -2,7 +2,7 @@
+ LDLIBS += 
+ SRCS=$(wildcard *.c)
+-TARGETS=$(patsubst %.c,%,$(SRCS))
++TARGETS=#$(patsubst %.c,%,$(SRCS))
+ all: $(TARGETS)
+--- ltp-full-20031002/tools/netpipe-2.4-ipv6/Makefile.orig     2003-10-02 19:38:07.000000000 -0600
++++ ltp-full-20031002/tools/netpipe-2.4-ipv6/Makefile  2003-10-02 19:38:38.000000000 -0600
+@@ -10,7 +10,7 @@
+ DRIV_OBJ   = netpipe.o
+ INCLUDES   = netpipe.h
+ # Default target is just TCP
+-TARGETS    = NPtcp-ipv6
++TARGETS    = #NPtcp-ipv6
+ # If you have TCP, MPI and PVM
+ #TARGETS    = NPtcp NPmpi NPpvm
+ CFLAGS                    += -O -Wall