python: fix modules_lib_dirs typo in patch-2.7-005-stagng-headers-libs.patch
authorMark Wickham <markw@digi.com>
Fri, 4 Feb 2011 18:45:46 +0000 (19:45 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 4 Feb 2011 18:46:45 +0000 (19:46 +0100)
Closes #3169

Typo in modules_lib_dirs section of patch specified modules_include_dirs
instead of modules_lib_dirs.  This matters if PYTHON_MODULES_LIB
is not passed into the script.

Signed-off-by: Mark Wickham <markw@digi.com>
Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/python/python-2.7-005-staging-headers-libs.patch

diff --git a/CHANGES b/CHANGES
index f3293dc3098cb3c43b3980142fb6ad9c67bf8b4d..61a51fbbb6a4c04335bb23efd9534a1b32cb2d45 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -97,6 +97,7 @@
        #3103: make external-deps wants to download gcc-.tar.bz2 when...
        #3109: abnormal `make busybox-menuconfig`
        #3115: How about board specific makefiles?
+       #3169: python patch has typo, aborts build in scenario
        #3181: dhcp.mk copies S80dhcp-server to etc/init.d, not etc/init.d/
 
 2010.11, Released November 30th, 2010:
index ab3d88e7367735519226ba7ee6216e72583adea5..170e81970960ab9d5301b5fddaee326343c853ba 100644 (file)
@@ -27,7 +27,7 @@ Index: Python-2.7.1/setup.py
 +        try:
 +            modules_lib_dirs = os.environ["PYTHON_MODULES_LIB"].split()
 +        except KeyError:
-+            modules_include_dirs = ['/usr/lib']
++            modules_lib_dirs = ['/usr/lib']
 +        for dir in modules_include_dirs:
 +            add_dir_to_list(self.compiler.include_dirs, dir)
 +        for dir in modules_lib_dirs: