package/libimxvpuapi: make it a waf-package
authorYann E. MORIN <yann.morin.1998@free.fr>
Sun, 30 Oct 2016 16:02:19 +0000 (17:02 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 2 Dec 2016 21:37:55 +0000 (22:37 +0100)
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Gary Bisson <gary.bisson@boundarydevices.com>
Reviewed-by: Romain Naour <romain.naour@gmail.com>
Tested-by: Gary Bisson <gary.bisson@boundarydevices.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libimxvpuapi/libimxvpuapi.mk

index df84806234f94ad2b01cf5ce1e85a7719ab28d24..fde44293755ac3ef846dcb6289a6ae6365181001 100644 (file)
@@ -11,25 +11,4 @@ LIBIMXVPUAPI_LICENSE_FILES = LICENSE
 LIBIMXVPUAPI_DEPENDENCIES = host-pkgconf host-python imx-vpu
 LIBIMXVPUAPI_INSTALL_STAGING = YES
 
-define LIBIMXVPUAPI_CONFIGURE_CMDS
-       cd $(@D); \
-       $(TARGET_CONFIGURE_OPTS) $(HOST_DIR)/usr/bin/python2 ./waf configure \
-               --prefix=/usr --libdir=/usr/lib
-endef
-
-define LIBIMXVPUAPI_BUILD_CMDS
-       cd $(@D); \
-       $(HOST_DIR)/usr/bin/python2 ./waf build -j $(PARALLEL_JOBS)
-endef
-
-define LIBIMXVPUAPI_INSTALL_STAGING_CMDS
-       cd $(@D); \
-       $(HOST_DIR)/usr/bin/python2 ./waf --destdir=$(STAGING_DIR) install
-endef
-
-define LIBIMXVPUAPI_INSTALL_TARGET_CMDS
-       cd $(@D); \
-       $(HOST_DIR)/usr/bin/python2 ./waf --destdir=$(TARGET_DIR) install
-endef
-
-$(eval $(generic-package))
+$(eval $(waf-package))