busybox: add 1.14.x
authorPeter Korsgaard <jacmet@sunsite.dk>
Wed, 15 Apr 2009 13:42:03 +0000 (13:42 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 15 Apr 2009 13:42:03 +0000 (13:42 -0000)
package/busybox/Config.in
package/busybox/busybox.mk

index 12af1b38901d3b3d4fceb95061bd070def0d5ad7..92081d03c689e5b68c4a15bde07fb2d0efb6fd88 100644 (file)
@@ -12,7 +12,7 @@ config BR2_PACKAGE_BUSYBOX
 choice
        prompt "BusyBox Version"
        depends on BR2_PACKAGE_BUSYBOX
-       default BR2_BUSYBOX_VERSION_1_13_X
+       default BR2_BUSYBOX_VERSION_1_14_X
        help
          Select the version of BusyBox you wish to use.
 
@@ -46,10 +46,14 @@ choice
 
        config BR2_BUSYBOX_VERSION_1_12_X
                bool "BusyBox 1.12.x"
-               depends on BR2_DEPRECATED || BR2_RECENT
+               depends on BR2_DEPRECATED
 
        config BR2_BUSYBOX_VERSION_1_13_X
                bool "BusyBox 1.13.x"
+               depends on BR2_DEPRECATED || BR2_RECENT
+
+       config BR2_BUSYBOX_VERSION_1_14_X
+               bool "BusyBox 1.14.x"
 
        config BR2_PACKAGE_BUSYBOX_SNAPSHOT
                bool "daily snapshot"
@@ -67,6 +71,7 @@ config BR2_BUSYBOX_VERSION
        default "1.11.3"        if BR2_BUSYBOX_VERSION_1_11_X
        default "1.12.4"        if BR2_BUSYBOX_VERSION_1_12_X
        default "1.13.4"        if BR2_BUSYBOX_VERSION_1_13_X
+       default "1.14.0"        if BR2_BUSYBOX_VERSION_1_14_X
 
 config BR2_PACKAGE_BUSYBOX_FULLINSTALL
        bool "Run BusyBox's own full installation"
@@ -94,6 +99,7 @@ config BR2_PACKAGE_BUSYBOX_CONFIG
        default "package/busybox/busybox-1.11.x.config" if BR2_BUSYBOX_VERSION_1_11_X
        default "package/busybox/busybox-1.11.x.config" if BR2_BUSYBOX_VERSION_1_12_X
        default "package/busybox/busybox-1.13.x.config" if BR2_BUSYBOX_VERSION_1_13_X
+       default "package/busybox/busybox-1.13.x.config" if BR2_BUSYBOX_VERSION_1_14_X
        help
          Some people may wish to use their own modified BusyBox configuration
          file, and will specify their config file location with this option.
index 8e725104656a8a4a8130a308209b57c90314d764..378a6f4d99d10215eef236e387f68a498d1e89b9 100644 (file)
@@ -52,8 +52,8 @@ ifeq ($(BR2_BUSYBOX_VERSION_1_2_2_1),y)
        $(SED) s,^PREFIX=.*,CROSS_COMPILER_PREFIX=\"$(TARGET_CROSS)\", \
                $(BUSYBOX_DIR)/.config
 endif
-# id applet breaks on 1.13.0 with old uclibc unless the bb pwd routines are used
-ifeq ($(BR2_BUSYBOX_VERSION_1_13_X)$(BR2_UCLIBC_VERSION_0_9_28_3)$(BR2_UCLIBC_VERSION_0_9_29),yy)
+# id applet breaks on >=1.13.0 with old uclibc unless the bb pwd routines are used
+ifeq ($(BR2_BUSYBOX_VERSION_1_13_X)$(BR2_BUSYBOX_VERSION_1_14_X)$(BR2_UCLIBC_VERSION_0_9_28_3)$(BR2_UCLIBC_VERSION_0_9_29),yy)
        if grep -q 'CONFIG_ID=y' $(BUSYBOX_DIR)/.config; \
        then \
                echo 'warning: CONFIG_ID needs BB_PWD_GRP with old uclibc, enabling' >&2;\