libsecret: specify where libgcrypt lives
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Tue, 3 Sep 2013 13:27:21 +0000 (10:27 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 3 Sep 2013 14:38:22 +0000 (16:38 +0200)
When libgcrypt support is enabled the configure script will try to
find libgcrypt-config in the PATH. If the host distribution has it then
brokeness ensues. Fixes:
http://autobuild.buildroot.net/results/eca/eca10b8360354e7e51406f7ac942d343987bde5e/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/libsecret/libsecret.mk

index e445ea6f00711a3c22fed87cdbf9598011fe82e3..a0f39f8b0a35ee2aa75c4d81a9d5c31b8968140e 100644 (file)
@@ -16,7 +16,8 @@ LIBSECRET_CONF_OPT = --disable-manpages --disable-strict --disable-coverage --en
 
 ifeq ($(BR2_PACKAGE_LIBGCRYPT),y)
        LIBSECRET_DEPENDENCIES += libgcrypt
-       LIBSECRET_CONF_OPT += --enable-gcrypt
+       LIBSECRET_CONF_OPT += --enable-gcrypt \
+               --with-libgcrypt-prefix=$(STAGING_DIR)/usr
 else
        LIBSECRET_CONF_OPT += --disable-gcrypt
 endif