readline: use normal/default install target
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 12 Aug 2013 13:37:46 +0000 (10:37 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 13 Aug 2013 08:18:27 +0000 (10:18 +0200)
Since the custom INSTALL_TARGET doesn't consider static builds it breaks
horribly and there's no need with the current version since it works
just fine with a little varnish to remove samples. Fixes:
http://autobuild.buildroot.net/results/5a6/5a62c38ec621d49230d76981db6024035e88804a/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/readline/readline.mk

index 0c883bcf92bb29fce5628be125c30ba8dd3ef24c..ff5519924c61b14f7ff2a644fd2b625103a43f63 100644 (file)
@@ -13,14 +13,10 @@ READLINE_CONF_ENV = bash_cv_func_sigsetjmp=yes
 READLINE_LICENSE = GPLv3+
 READLINE_LICENSE_FILES = COPYING
 
-define READLINE_INSTALL_TARGET_CMDS
-       $(MAKE1) DESTDIR=$(TARGET_DIR) -C $(@D) uninstall
-       $(MAKE1) DESTDIR=$(TARGET_DIR) -C $(@D) install-shared uninstall-doc
-       chmod 775 $(TARGET_DIR)/usr/lib/libreadline.so.$(READLINE_VERSION) \
-               $(TARGET_DIR)/usr/lib/libhistory.so.$(READLINE_VERSION)
-       $(STRIPCMD) $(STRIP_STRIP_UNNEEDED) \
-               $(TARGET_DIR)/usr/lib/libreadline.so.$(READLINE_VERSION) \
-               $(TARGET_DIR)/usr/lib/libhistory.so.$(READLINE_VERSION)
+define READLINE_PURGE_EXAMPLES
+       rm -rf $(TARGET_DIR)/usr/share/readline
 endef
 
+READLINE_POST_INSTALL_TARGET_HOOKS += READLINE_PURGE_EXAMPLES
+
 $(eval $(autotools-package))