wireshark: security bump to version 1.12.5
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 1 Jun 2015 15:26:21 +0000 (12:26 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 1 Jun 2015 21:54:14 +0000 (23:54 +0200)
Fixes:
CVE-2015-3808 CVE-2015-3809 - The LBMR dissector could go into an
infinite loop.
CVE-2015-3811 - The WCP dissector could crash while decompressing data.
CVE-2015-3812 - The X11 dissector could leak memory.
CVE-2015-3813 - The packet reassembly code could leak memory.
CVE-2015-3814 - The IEEE 802.11 dissector could go into an infinite
loop.
CVE-2015-3815 - The Android Logcat file parser could crash.

Patch upstream so drop and disable autoreconf.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/wireshark/0001-fix-wrong-cflags-for-build-assumption.patch [deleted file]
package/wireshark/wireshark.hash
package/wireshark/wireshark.mk

diff --git a/package/wireshark/0001-fix-wrong-cflags-for-build-assumption.patch b/package/wireshark/0001-fix-wrong-cflags-for-build-assumption.patch
deleted file mode 100644 (file)
index 14cb957..0000000
+++ /dev/null
@@ -1,38 +0,0 @@
-AC_WIRESHARK_GCC_CFLAGS_CHECK checks for valid CFLAGS against CC and pushes
-them into CFLAGS and CFLAGS_FOR_BUILD.
-This is wrong since CC_FOR_BUILD might be wildly different and older than CC
-leading to build errors.
-
-Upstream status: reported in tracker
-https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=9507
-
-Patch status: Interim to fix:
-http://autobuild.buildroot.net/results/2b1/2b1a0654b649618422d65edf370b82476ba84491/
-
-Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
-
-diff -Nura wireshark-1.12.0.orig/acinclude.m4 wireshark-1.12.0/acinclude.m4
---- wireshark-1.12.0.orig/acinclude.m4 2014-09-04 15:45:38.365255309 -0300
-+++ wireshark-1.12.0/acinclude.m4      2014-09-04 15:46:23.349810353 -0300
-@@ -1755,10 +1755,6 @@
-               # just the new option.
-               #
-               CFLAGS="$CFLAGS_saved $GCC_OPTION"
--              #
--              # Add it to the flags we use when building build tools.
--              #
--              CFLAGS_FOR_BUILD="$CFLAGS_FOR_BUILD $GCC_OPTION"
-             ],
-             [
-               AC_MSG_RESULT(yes)
-@@ -1771,10 +1767,6 @@
-           # just the new option.
-           #
-           CFLAGS="$CFLAGS_saved $GCC_OPTION"
--          #
--          # Add it to the flags we use when building build tools.
--          #
--          CFLAGS_FOR_BUILD="$CFLAGS_FOR_BUILD $GCC_OPTION"
-         fi
-       ],
-       [
index fa4cf181048ba017f7f1bc431ea29e80184593d7..35eb1a2292f7e2a9f0cc1fe12b5ac3cddc3916ec 100644 (file)
@@ -1,3 +1,3 @@
-# From https://www.wireshark.org/download/SIGNATURES-1.12.4.txt
-md5    acfa156fd35cb66c867b1ace992e4b5b        wireshark-1.12.4.tar.bz2
-sha1   dbbd4090c02fe170f35b26fa26d8aba0b399c659        wireshark-1.12.4.tar.bz2
+# From https://www.wireshark.org/download/SIGNATURES-1.12.5.txt
+md5    9ee199dde4f36a3d71f7b81dd6764e93        wireshark-1.12.5.tar.bz2
+sha1   379686f0b6355ae2e6b3f7055578317a07ce5590        wireshark-1.12.5.tar.bz2
index 434687c90b2fe385a1c4ac00fbbab70dfad69924..eb568085cce7070cfc9ea0038c6e16bb9cd9416a 100644 (file)
@@ -4,14 +4,12 @@
 #
 ################################################################################
 
-WIRESHARK_VERSION = 1.12.4
+WIRESHARK_VERSION = 1.12.5
 WIRESHARK_SOURCE = wireshark-$(WIRESHARK_VERSION).tar.bz2
 WIRESHARK_SITE = http://www.wireshark.org/download/src/all-versions
 WIRESHARK_LICENSE = wireshark license
 WIRESHARK_LICENSE_FILES = COPYING
 WIRESHARK_DEPENDENCIES = libpcap libgcrypt libglib2
-# For wrong cflags patch
-WIRESHARK_AUTORECONF = YES
 WIRESHARK_CONF_ENV = \
        LIBGCRYPT_CONFIG=$(STAGING_DIR)/usr/bin/libgcrypt-config \
        ac_cv_path_PCAP_CONFIG=$(STAGING_DIR)/usr/bin/pcap-config