Fix bug #0005884 - pciutils depends on zlib
authorThiago A. Corrêa <thiago.correa@gmail.com>
Fri, 31 Oct 2008 04:03:27 +0000 (04:03 -0000)
committerThiago A. Corrêa <thiago.correa@gmail.com>
Fri, 31 Oct 2008 04:03:27 +0000 (04:03 -0000)
package/pciutils/Config.in
package/pciutils/pciutils.mk

index a082f239977dc43f71b6e77a08dd1380f0e13330..18bd65587aa1a640bebab926a9bfa82100b53170 100644 (file)
@@ -1,5 +1,6 @@
 config BR2_PACKAGE_PCIUTILS
        bool "pciutils"
+       depends on BR2_PACKAGE_ZLIB
        help
          Various utilities dealing with the PCI bus.
          Provides things like setpci and lspci.
index 805a4d320892f39b61f3fc70a070f0bd0276c45a..14c548933dff8a77f062dbacf1653d00067d18ab 100644 (file)
@@ -43,7 +43,7 @@ $(TARGET_DIR)/sbin/setpci: $(PCIUTILS_DIR)/.compiled
 $(TARGET_DIR)/usr/share/misc/pci.ids: $(PCIUTILS_DIR)/.unpacked
        install -Dc $(PCIUTILS_DIR)/pci.ids $(TARGET_DIR)/usr/share/misc/pci.ids
 
-pciutils: uclibc $(TARGET_DIR)/sbin/setpci $(TARGET_DIR)/sbin/lspci $(TARGET_DIR)/usr/share/misc/pci.ids
+pciutils: uclibc zlib $(TARGET_DIR)/sbin/setpci $(TARGET_DIR)/sbin/lspci $(TARGET_DIR)/usr/share/misc/pci.ids
 
 pciutils-clean:
        rm $(TARGET_DIR)/sbin/lspci $(TARGET_DIR)/sbin/setpci $(TARGET_DIR)/usr/share/misc/pci.ids