package: add python-webob
authorPeter Korsgaard <peter@korsgaard.com>
Wed, 23 May 2018 11:32:36 +0000 (13:32 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 25 May 2018 16:03:51 +0000 (18:03 +0200)
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
DEVELOPERS
package/Config.in
package/python-webob/Config.in [new file with mode: 0644]
package/python-webob/python-webob.hash [new file with mode: 0644]
package/python-webob/python-webob.mk [new file with mode: 0644]

index 78c356fed90db1bd461cf8a2cedeb577be691454..63d554bf281c3f0b2366b5bf77a59bf61c3d24c7 100644 (file)
@@ -1493,6 +1493,7 @@ F:        package/python-ipaddr/
 F:     package/python-pam/
 F:     package/python-psutil/
 F:     package/python-texttable/
+F:     package/python-webob/
 F:     package/python-websocket-client/
 F:     package/triggerhappy/
 
index b66f27a08379e2af5bd77fc7383a6fec5f411249..277186becb2db01d541427d205a98649e670002f 100644 (file)
@@ -969,6 +969,7 @@ menu "External python modules"
        source "package/python-watchdog/Config.in"
        source "package/python-wcwidth/Config.in"
        source "package/python-web2py/Config.in"
+       source "package/python-webob/Config.in"
        source "package/python-webpy/Config.in"
        source "package/python-websocket-client/Config.in"
        source "package/python-websockets/Config.in"
diff --git a/package/python-webob/Config.in b/package/python-webob/Config.in
new file mode 100644 (file)
index 0000000..fe77723
--- /dev/null
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_PYTHON_WEBOB
+       bool "python-webob"
+       select BR2_PACKAGE_PYTHON_HASHLIB if BR2_PACKAGE_PYTHON # runtime
+       select BR2_PACKAGE_PYTHON_ZLIB if BR2_PACKAGE_PYTHON # runtime
+       select BR2_PACKAGE_PYTHON3_ZLIB if BR2_PACKAGE_PYTHON3 # runtime
+       help
+         WSGI request and response object.
+
+         http://webob.org/
diff --git a/package/python-webob/python-webob.hash b/package/python-webob/python-webob.hash
new file mode 100644 (file)
index 0000000..41e8af3
--- /dev/null
@@ -0,0 +1,5 @@
+# md5, sha256 from https://pypi.org/pypi/WebOb/json
+md5    afea95e4f08330a0529ae33137caf4f0  WebOb-1.8.1.tar.gz
+sha256 54f35073d2fdcddd7a98c2a1dedeede49739150737164a787220f30283139ba6  WebOb-1.8.1.tar.gz
+# Locally computed sha256 checksums
+sha256 27bc4919e7e9e6b6cda40644517ca74d32203e32fba89ef832aba1ed93e457b3  docs/license.txt
diff --git a/package/python-webob/python-webob.mk b/package/python-webob/python-webob.mk
new file mode 100644 (file)
index 0000000..fdf4793
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-webob
+#
+################################################################################
+
+PYTHON_WEBOB_VERSION = 1.8.1
+PYTHON_WEBOB_SOURCE = WebOb-$(PYTHON_WEBOB_VERSION).tar.gz
+PYTHON_WEBOB_SITE = https://files.pythonhosted.org/packages/ea/93/675ec37b631c823877718164b74fc057203c8979fd771bf60f711d64550b
+PYTHON_WEBOB_SETUP_TYPE = setuptools
+PYTHON_WEBOB_LICENSE = MIT
+PYTHON_WEBOB_LICENSE_FILES = docs/license.txt
+
+$(eval $(python-package))