perl-number-bytes-human: new package
authorChristopher McCrory <chrismcc@gmail.com>
Fri, 10 Aug 2018 16:14:57 +0000 (09:14 -0700)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 13 Aug 2018 09:46:44 +0000 (11:46 +0200)
Signed-off-by: Christopher McCrory <chrismcc@gmail.com>
Acked-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/perl-number-bytes-human/Config.in [new file with mode: 0644]
package/perl-number-bytes-human/perl-number-bytes-human.hash [new file with mode: 0644]
package/perl-number-bytes-human/perl-number-bytes-human.mk [new file with mode: 0644]

index 91659b364b12294302c418b4e9fb0986cae12f05..3b55b679c352dcda0dd9e30c44e74bfc11c0314f 100644 (file)
@@ -492,6 +492,7 @@ F:  package/perl-file-slurp/
 F:     package/perl-io-interface/
 F:     package/perl-json-maybexs/
 F:     package/perl-module-runtime/
+F:     package/perl-number-bytes-human/
 
 N:     Clayton Shotwell <clayton.shotwell@rockwellcollins.com>
 F:     package/audit/
index 4a6fd22238b7ff59fcb0b9fade3a5603b07844a7..feaa289aa00b7cd8a1f1b557fc2d09c49d05783f 100644 (file)
@@ -718,6 +718,7 @@ menu "Perl libraries/modules"
        source "package/perl-net-ssleay/Config.in"
        source "package/perl-net-telnet/Config.in"
        source "package/perl-netaddr-ip/Config.in"
+       source "package/perl-number-bytes-human/Config.in"
        source "package/perl-path-tiny/Config.in"
        source "package/perl-time-hires/Config.in"
        source "package/perl-timedate/Config.in"
diff --git a/package/perl-number-bytes-human/Config.in b/package/perl-number-bytes-human/Config.in
new file mode 100644 (file)
index 0000000..ca43873
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_PERL_NUMBER_BYTES_HUMAN
+       bool "perl-number-bytes-human"
+       help
+         Convert byte count to human readable format
+
+         https://metacpan.org/release/Number-Bytes-Human
diff --git a/package/perl-number-bytes-human/perl-number-bytes-human.hash b/package/perl-number-bytes-human/perl-number-bytes-human.hash
new file mode 100644 (file)
index 0000000..af7a6b6
--- /dev/null
@@ -0,0 +1,6 @@
+# retrieved by scancpan from http://cpan.metacpan.org/
+md5    43d2c86a55924aa71535a41de0311efd Number-Bytes-Human-0.11.tar.gz
+sha256 5fc79c49b0b40df780479c43696381343e2b6ad1fe52859f60bc65b66ebe6f2c Number-Bytes-Human-0.11.tar.gz
+
+# computed by scancpan
+sha256 d42143fe4b63cb5d488d65a44e6c55769b098ea447462ff33316b33a837b7cf9 README
diff --git a/package/perl-number-bytes-human/perl-number-bytes-human.mk b/package/perl-number-bytes-human/perl-number-bytes-human.mk
new file mode 100644 (file)
index 0000000..e10c550
--- /dev/null
@@ -0,0 +1,13 @@
+################################################################################
+#
+# perl-number-bytes-human
+#
+################################################################################
+
+PERL_NUMBER_BYTES_HUMAN_VERSION = 0.11
+PERL_NUMBER_BYTES_HUMAN_SOURCE = Number-Bytes-Human-$(PERL_NUMBER_BYTES_HUMAN_VERSION).tar.gz
+PERL_NUMBER_BYTES_HUMAN_SITE = $(BR2_CPAN_MIRROR)/authors/id/F/FE/FERREIRA
+PERL_NUMBER_BYTES_HUMAN_LICENSE = Artistic or GPL-1.0+
+PERL_NUMBER_BYTES_HUMAN_LICENSE_FILES = README
+
+$(eval $(perl-package))