rpi-firmware: allow disabling installation of binary DTBs
authorFloris Bos <bos@je-eigen-domein.nl>
Sun, 28 Jun 2015 22:25:10 +0000 (00:25 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 29 Jun 2015 20:13:56 +0000 (22:13 +0200)
The binary .dtb files are not suitable for everyone as they are
kernel-version specific.

Reintroduce BR2_PACKAGE_RPI_FIRMWARE_INSTALL_DTBS option.

Signed-off-by: Floris Bos <bos@je-eigen-domein.nl>
[yann.morin.1998@free.fr: don't install DTBs if kernel builds
 its own; fix default; rephrase help text]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
Cc: Pascal de Bruijn <pmjdebruijn@pcode.nl>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/rpi-firmware/Config.in
package/rpi-firmware/rpi-firmware.mk

index cd45be4ea45a8a98a241b48de46a3fbb1f0b1dd8..179fb47368ff2d3a52e29350d3b30fcc817269b7 100644 (file)
@@ -45,4 +45,16 @@ config BR2_PACKAGE_RPI_FIRMWARE_BOOT
        default "_x"    if BR2_PACKAGE_RPI_FIRMWARE_X
        default "_cd"   if BR2_PACKAGE_RPI_FIRMWARE_CD
 
+config BR2_PACKAGE_RPI_FIRMWARE_INSTALL_DTBS
+       bool "Install Device Tree Blobs (DTBs)"
+       depends on !BR2_LINUX_KERNEL_DTS_SUPPORT
+       default y
+       help
+         If you are using a Linux kernel <= 3.18, you should say 'y' here.
+
+         If you are using a Linux kernel >= 3.19, you should say 'n' here,
+         and enable BR2_LINUX_KERNEL_DTS_SUPPORT to let the kernel build
+         the DTB.
+
+
 endif # BR2_PACKAGE_RPI_FIRMWARE
index cbcf790095289c4c52886f2abb8f9aa11ce86ce6..9cccb388f80daabf4a63dfd0b97db751fb779b09 100644 (file)
@@ -13,6 +13,7 @@ RPI_FIRMWARE_INSTALL_IMAGES = YES
 
 RPI_FIRMWARE_DEPENDENCIES += host-rpi-firmware
 
+ifeq ($(BR2_PACKAGE_RPI_FIRMWARE_INSTALL_DTBS),y)
 define RPI_FIRMWARE_INSTALL_DTB
        $(INSTALL) -D -m 0644 $(@D)/boot/bcm2708-rpi-b.dtb $(BINARIES_DIR)/rpi-firmware/bcm2708-rpi-b.dtb
        $(INSTALL) -D -m 0644 $(@D)/boot/bcm2708-rpi-b-plus.dtb $(BINARIES_DIR)/rpi-firmware/bcm2708-rpi-b-plus.dtb
@@ -21,6 +22,7 @@ define RPI_FIRMWARE_INSTALL_DTB
                $(INSTALL) -D -m 0644 $${ovldtb} $(BINARIES_DIR)/rpi-firmware/overlays/$${ovldtb##*/} || exit 1; \
        done
 endef
+endif
 
 define RPI_FIRMWARE_INSTALL_IMAGES_CMDS
        $(INSTALL) -D -m 0644 $(@D)/boot/bootcode.bin $(BINARIES_DIR)/rpi-firmware/bootcode.bin