core/skeleton: drop /etc/securetty
authorYann E. MORIN <yann.morin.1998@free.fr>
Mon, 13 Jul 2015 09:05:35 +0000 (11:05 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 13 Jul 2015 11:00:50 +0000 (13:00 +0200)
securetty is supposed to restrict the terminals root is allowed to
login from. As it happens, login from busybox (w/ securetty support)
is actually enforcing use of securetty, while login from util-linux
is completely ignoring securetty altogether.

Remove securetty from our skeleton altogether and stop worrying about
it.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Cc: Arnout Vandecappelle <arnout@mind.be>
Cc: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/util-linux/login.pam
system/skeleton/etc/securetty [deleted file]
system/system.mk

index 1d9cd70e1e2e373b669f245f9dfe917b2f6e1a09..01f56324daf691e5755bd9c378fb5755b1551949 100644 (file)
@@ -1,4 +1,3 @@
-auth           required        pam_securetty.so
 auth           required        pam_unix.so nullok
 
 account                required        pam_unix.so
diff --git a/system/skeleton/etc/securetty b/system/skeleton/etc/securetty
deleted file mode 100644 (file)
index 0722677..0000000
+++ /dev/null
@@ -1,57 +0,0 @@
-tty1
-tty2
-tty3
-tty4
-tty5
-tty6
-tty7
-tty8
-ttyS0
-ttyS1
-ttyS2
-ttyS3
-ttyAMA0
-ttyAMA1
-ttyAMA2
-ttyAMA3
-ttySAC0
-ttySAC1
-ttySAC2
-ttySAC3
-ttyUL0
-ttyUL1
-ttyUL2
-ttyUL3
-ttyPS0
-ttyPS1
-ttyPSC0
-ttyPSC1
-ttyPSC2
-ttyPSC3
-ttyCPM0
-ttyCPM1
-ttyCPM2
-ttyCPM3
-ttymxc0
-ttymxc1
-ttymxc2
-ttyO0
-ttyO1
-ttyO2
-ttyO3
-ttyAM0
-ttyAM1
-ttyAM2
-ttySC0
-ttySC1
-ttySC2
-ttySC3
-ttySC4
-ttySC5
-ttySC6
-ttySC7
-ttyGS0
-hvc0
-hvc1
-hvc2
-hvc3
index 279466741f15ae2ef130aeaf25e3b66ac0a7f10c..fd94e03a279752f1a92d19fa61e7aeffbebfa621 100644 (file)
@@ -8,14 +8,6 @@ TARGET_GENERIC_GETTY_BAUDRATE = $(call qstrip,$(BR2_TARGET_GENERIC_GETTY_BAUDRAT
 TARGET_GENERIC_GETTY_TERM = $(call qstrip,$(BR2_TARGET_GENERIC_GETTY_TERM))
 TARGET_GENERIC_GETTY_OPTIONS = $(call qstrip,$(BR2_TARGET_GENERIC_GETTY_OPTIONS))
 
-ifeq ($(BR2_TARGET_GENERIC_GETTY),y)
-define SYSTEM_SECURETTY
-       grep -q '^$(TARGET_GENERIC_GETTY_PORT)$$' $(TARGET_DIR)/etc/securetty || \
-               echo '$(TARGET_GENERIC_GETTY_PORT)' >> $(TARGET_DIR)/etc/securetty
-endef
-TARGET_FINALIZE_HOOKS += SYSTEM_SECURETTY
-endif
-
 ifneq ($(TARGET_GENERIC_HOSTNAME),)
 define SYSTEM_HOSTNAME
        mkdir -p $(TARGET_DIR)/etc