toolchain-external: wrap gfortran
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>
Mon, 4 Jul 2016 12:26:35 +0000 (13:26 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 4 Jul 2016 12:55:06 +0000 (14:55 +0200)
Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
toolchain/toolchain-external/toolchain-external.mk

index a31a04be3ca8cf63c2a19c5a233aa472dcc72979..c103b96c9adf954521774a36f479e76d5b0f5a03 100644 (file)
@@ -729,9 +729,9 @@ define TOOLCHAIN_EXTERNAL_INSTALL_TARGET_BFIN_FLAT
 endef
 endif
 
-# Build toolchain wrapper for preprocessor, C and C++ compiler and setup
-# symlinks for everything else. Skip gdb symlink when we are building our
-# own gdb to prevent two gdb's in output/host/usr/bin.
+# Build toolchain wrapper for preprocessor, C, C++ and Fortran compilers
+# and setup symlinks for everything else. Skip gdb symlink when we are
+# building our own gdb to prevent two gdb's in output/host/usr/bin.
 # The LTO support in gcc creates wrappers for ar, ranlib and nm which load
 # the lto plugin. These wrappers are called *-gcc-ar, *-gcc-ranlib, and
 # *-gcc-nm and should be used instead of the real programs when -flto is
@@ -746,7 +746,7 @@ define TOOLCHAIN_EXTERNAL_INSTALL_WRAPPER
                *-ar|*-ranlib|*-nm) \
                        ln -sf $$(echo $$i | sed 's%^$(HOST_DIR)%../..%') .; \
                        ;; \
-               *cc|*cc-*|*++|*++-*|*cpp) \
+               *cc|*cc-*|*++|*++-*|*cpp|*-gfortran) \
                        ln -sf toolchain-wrapper $$base; \
                        ;; \
                *gdb|*gdbtui) \