Fix microblize little endian toolchain
authorJan Drazil <xdrazi00@stud.fit.vutbr.cz>
Wed, 19 Mar 2014 12:01:05 +0000 (13:01 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 20 Mar 2014 15:46:29 +0000 (16:46 +0100)
Buildroot toolchain creates big endian binaries instead of little endian
ones for microblaze architecture. The reason is wrong BR2_ARCH string.
KERNEL_ARCH must contain microblaze in both cases.

Signed-off-by: Jan Drazil <xdrazi00@stud.fit.vutbr.cz>
Signed-off-by: Jan Viktorin <xvikto03@stud.fit.vutbr.cz>
Acked-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Tested-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Makefile
arch/Config.in.microblaze

index 011af57620644cafb6692045ad11b3a433298eaa..d49d7bf6b297d6b5a1ecdfec1e20df62c1a8c410 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -318,7 +318,8 @@ KERNEL_ARCH:=$(shell echo "$(ARCH)" | sed -e "s/-.*//" \
        -e s/parisc64/parisc/ \
        -e s/powerpc64/powerpc/ \
        -e s/ppc.*/powerpc/ -e s/mips.*/mips/ \
-       -e s/sh.*/sh/)
+       -e s/sh.*/sh/ \
+       -e s/microblazeel/microblaze/)
 
 ZCAT:=$(call qstrip,$(BR2_ZCAT))
 BZCAT:=$(call qstrip,$(BR2_BZCAT))
index dbdd99a19b2f60cc156d92eff9876b751050b08d..2d4c1fec439d470be55ed4fcc6703e54b892cbea 100644 (file)
@@ -1,5 +1,6 @@
 config BR2_ARCH
-       default "microblaze"
+       default "microblazeel"  if BR2_microblazeel
+       default "microblaze"    if BR2_microblazebe
 
 config BR2_ENDIAN
        default "LITTLE" if BR2_microblazeel