libtommath: new package
authorFrancois Perrad <fperrad@gmail.com>
Sun, 10 Apr 2016 14:55:24 +0000 (16:55 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 28 Apr 2016 17:41:09 +0000 (19:41 +0200)
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Reviewed-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/Config.in
package/libtommath/Config.in [new file with mode: 0644]
package/libtommath/libtommath.hash [new file with mode: 0644]
package/libtommath/libtommath.mk [new file with mode: 0644]

index c7d415c16dbacf329541151fd4b5a0b2c3e7bba9..e645dfe2c5c6abe8e1d70854d025261b97509c08 100644 (file)
@@ -1244,6 +1244,7 @@ menu "Other"
        source "package/libsigc/Config.in"
        source "package/libsigsegv/Config.in"
        source "package/libtasn1/Config.in"
+       source "package/libtommath/Config.in"
        source "package/libtpl/Config.in"
        source "package/libubox/Config.in"
        source "package/libuci/Config.in"
diff --git a/package/libtommath/Config.in b/package/libtommath/Config.in
new file mode 100644 (file)
index 0000000..b2ffc72
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_LIBTOMMATH
+       bool "libtommath"
+       help
+         LibTomMath is a free open source portable number theoretic
+         multiple-precision integer library written entirely in C.
+
+         http://www.libtom.net
diff --git a/package/libtommath/libtommath.hash b/package/libtommath/libtommath.hash
new file mode 100644 (file)
index 0000000..fcf2ddc
--- /dev/null
@@ -0,0 +1,2 @@
+# Locally computed
+sha256  993a7df9ee091fca430cdde3263df57d88ef62af8103903214da49fc51bbb56c  ltm-1.0.tar.xz
diff --git a/package/libtommath/libtommath.mk b/package/libtommath/libtommath.mk
new file mode 100644 (file)
index 0000000..463ea7b
--- /dev/null
@@ -0,0 +1,23 @@
+################################################################################
+#
+# libtommath
+#
+################################################################################
+
+LIBTOMMATH_VERSION = 1.0
+LIBTOMMATH_SITE = https://github.com/libtom/libtommath/releases/download/v$(LIBTOMMATH_VERSION)
+LIBTOMMATH_SOURCE = ltm-$(LIBTOMMATH_VERSION).tar.xz
+LIBTOMMATH_LICENSE = WTFPL
+LIBTOMMATH_LICENSE_FILES = LICENSE
+LIBTOMMATH_INSTALL_STAGING = YES
+LIBTOMMATH_INSTALL_TARGET = NO  # only static library
+
+define LIBTOMMATH_BUILD_CMDS
+       $(MAKE) -C $(@D) $(TARGET_CONFIGURE_OPTS) CFLAGS="-I./ $(TARGET_CFLAGS)"
+endef
+
+define LIBTOMMATH_INSTALL_STAGING_CMDS
+       $(MAKE) -C $(@D) DESTDIR="$(STAGING_DIR)" install
+endef
+
+$(eval $(generic-package))