daemon: fix parallel build
authorBaruch Siach <baruch@tkos.co.il>
Mon, 8 May 2017 18:01:47 +0000 (21:01 +0300)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 9 May 2017 15:13:20 +0000 (17:13 +0200)
The 'ready' target creates a symlink in the libslack/ subdirectory to make
up the path to header files.  Unfortunately, the target building sources
files that need that symlink, does not depend on the 'ready' target.  This
might break highly parallel builds.  As a workaround make the 'ready' target
before making 'all'.

Should fix:
http://autobuild.buildroot.net/results/ed2/ed21ac166f2151aa69a7790a17ff05f05afa512d/
http://autobuild.buildroot.net/results/333/3338539743c8b0399c6b0fcbbb7c28b58bf3f387/

Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/daemon/daemon.mk

index dfa573f4265270dd6aa0bfc4945423bf1dd59d43..79cf3f7aab742d952ddab494561f72de7c958e14 100644 (file)
@@ -14,6 +14,7 @@ define DAEMON_CONFIGURE_CMDS
 endef
 
 define DAEMON_BUILD_CMDS
+       $(TARGET_MAKE_ENV) $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D) ready
        $(TARGET_MAKE_ENV) $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D)
 endef