package/libsvgtiny: enable shared library build
authorRomain Naour <romain.naour@openwide.fr>
Sat, 27 Dec 2014 21:58:21 +0000 (22:58 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 2 Jan 2015 11:23:25 +0000 (12:23 +0100)
[Thomas: clarify the comment explaining why we only build/install the
shared library when BR2_STATIC_SHARED_LIBS=y.]

Signed-off-by: Romain Naour <romain.naour@openwide.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libsvgtiny/libsvgtiny.mk

index a2d494eecf3b89c9c79204105d66b2e0dace8c07..3fc759f75d9d485e4dfdf49e540ea0a5380a4bcc 100644 (file)
@@ -11,18 +11,30 @@ LIBSVGTINY_DEPENDENCIES = libxml2 host-gperf host-pkgconf
 LIBSVGTINY_LICENSE = MIT
 LIBSVGTINY_LICENSE_FILES = README
 
+# The libsvgtiny build system cannot build both the shared and static
+# libraries. So when the Buildroot configuration requests to build
+# both the shared and static variants, we build only the shared one.
+ifeq ($(BR2_SHARED_LIBS)$(BR2_SHARED_STATIC_LIBS),y)
+LIBSVGTINY_COMPONENT_TYPE = lib-shared
+else
+LIBSVGTINY_COMPONENT_TYPE = lib-static
+endif
+
 define LIBSVGTINY_BUILD_CMDS
-       $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) PREFIX=/usr
+       $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) PREFIX=/usr \
+               COMPONENT_TYPE=$(LIBSVGTINY_COMPONENT_TYPE)
 endef
 
 define LIBSVGTINY_INSTALL_STAGING_CMDS
        $(TARGET_CONFIGURE_OPTS) \
-               $(MAKE) -C $(@D) PREFIX=/usr DESTDIR=$(STAGING_DIR) install
+               $(MAKE) -C $(@D) PREFIX=/usr DESTDIR=$(STAGING_DIR) \
+               COMPONENT_TYPE=$(LIBSVGTINY_COMPONENT_TYPE) install
 endef
 
 define LIBSVGTINY_INSTALL_TARGET_CMDS
        $(TARGET_CONFIGURE_OPTS) \
-               $(MAKE) -C $(@D) PREFIX=/usr DESTDIR=$(TARGET_DIR) install
+               $(MAKE) -C $(@D) PREFIX=/usr DESTDIR=$(TARGET_DIR) \
+               COMPONENT_TYPE=$(LIBSVGTINY_COMPONENT_TYPE) install
 endef
 
 $(eval $(generic-package))