Makefile: release: really drop build/docs from release tarball
authorPeter Korsgaard <peter@korsgaard.com>
Fri, 29 Mar 2019 21:19:35 +0000 (22:19 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 29 Mar 2019 22:09:41 +0000 (23:09 +0100)
Commit 15cb98769e4 (release: remove manual build files from release
tarballs) tried to remove the temporary files from the manual build from the
release tarball, but manual-clean only removes build/docs/manual and leaves
build/docs in the tarball.

Instead use 'make clean' to completely remove the build directory from the
tarball.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Makefile

index 37bbc421ade83c0f1e9b62cccb0c1709450e4713..60bf7d7d08989a33480c878c8e58448bbed5c23a 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1174,7 +1174,7 @@ release: OUT = buildroot-$(BR2_VERSION)
 release:
        git archive --format=tar --prefix=$(OUT)/ HEAD > $(OUT).tar
        $(MAKE) O=$(OUT) manual-html manual-text manual-pdf
-       $(MAKE) O=$(OUT) manual-clean
+       $(MAKE) O=$(OUT) clean
        tar rf $(OUT).tar $(OUT)
        gzip -9 -c < $(OUT).tar > $(OUT).tar.gz
        bzip2 -9 -c < $(OUT).tar > $(OUT).tar.bz2