ustr: remove source code from target
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 11 Oct 2018 20:11:35 +0000 (22:11 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 11 Oct 2018 21:09:30 +0000 (23:09 +0200)
For some reason, ustr installs its own source code, which means we end
up with 448 KB of source code in /usr/share in the target filesystem:

$ tree output/target/usr/share/
output/target/usr/share/
└── ustr-1.0.4
    ├── malloc-check.h
    ├── ustr-b-code.h
    ├── ustr-b-dbg-code.c
    ├── ustr-b-opt-code.c
    ├── ustr-cmp-code.h
    ├── ustr-cmp-dbg-code.c
    ├── ustr-cmp-internal.h
    ├── ustr-cmp-opt-code.c
    ├── ustr-cntl-code.h
    ├── ustr-fmt-code.h
    ├── ustr-fmt-dbg-code.c
    ├── ustr-fmt-internal.h
    [...]

$ du -sh output/target/usr/share/ustr-1.0.4/
448K output/target/usr/share/ustr-1.0.4/

So let's drop this source code in a post-install target hook.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/ustr/ustr.mk

index 8346adbcf28247938c5f644ea5f37f1b275ecd05..c99ada52767fd823f348b5e7c4d23ffa47d38846 100644 (file)
@@ -28,5 +28,12 @@ USTR_MAKE_OPTS = all all-shared
 USTR_CONF_OPTS += LDCONFIG=/bin/true
 HOST_USTR_CONF_OPTS += LDCONFIG=/bin/true
 
+# for some reason, ustr finds it useful to install its source code in
+# /usr/share, which is totally useless on the target
+define USTR_REMOVE_SOURCE_CODE
+       $(RM) -rf $(TARGET_DIR)/usr/share/ustr-$(USTR_VERSION)
+endef
+USTR_POST_INSTALL_TARGET_HOOKS += USTR_REMOVE_SOURCE_CODE
+
 $(eval $(autotools-package))
 $(eval $(host-autotools-package))