package/wpa_supplicant: adapt to systemctl preset-all
authorJérémy Rosen <jeremy.rosen@smile.fr>
Mon, 16 Dec 2019 10:30:48 +0000 (11:30 +0100)
committerYann E. MORIN <yann.morin.1998@free.fr>
Wed, 18 Dec 2019 17:33:22 +0000 (18:33 +0100)
All services were installed but not enabled.

This change enables the non-templated service but disables the
templated ones.

Enabling the templates creates weird links which are probably an
upstream bug.

Signed-off-by: Jérémy Rosen <jeremy.rosen@smile.fr>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/wpa_supplicant/50-wpa_supplicant.preset [new file with mode: 0644]
package/wpa_supplicant/wpa_supplicant.mk

diff --git a/package/wpa_supplicant/50-wpa_supplicant.preset b/package/wpa_supplicant/50-wpa_supplicant.preset
new file mode 100644 (file)
index 0000000..9af8562
--- /dev/null
@@ -0,0 +1,4 @@
+disable wpa_supplicant@.service
+disable wpa_supplicant-nl80211@.service
+disable wpa_supplicant-wired@.service
+
index 9dcebca9bf6e84275820c278cbaee33346fd073f..4f95ea6276c4b3df69d561f4939b2436858e26da 100644 (file)
@@ -227,6 +227,8 @@ define WPA_SUPPLICANT_INSTALL_INIT_SYSTEMD
                $(TARGET_DIR)/usr/lib/systemd/system/wpa_supplicant-nl80211@.service
        $(INSTALL) -m 0644 -D $(@D)/$(WPA_SUPPLICANT_SUBDIR)/systemd/wpa_supplicant-wired@.service \
                $(TARGET_DIR)/usr/lib/systemd/system/wpa_supplicant-wired@.service
+       $(INSTALL) -D -m 644 $(WPA_SUPPLICANT_PKGDIR)/50-wpa_supplicant.preset \
+               $(TARGET_DIR)/usr/lib/systemd/system-preset/50-wpa_supplicant.preset
 endef
 
 $(eval $(generic-package))