package/supertux: fix debug build on uclibc/musl
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 26 May 2019 19:18:14 +0000 (21:18 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Mon, 27 May 2019 21:48:41 +0000 (23:48 +0200)
Always set CMAKE_BUILD_TYPE to Release otherwise supertux will be built
with -pg since:
https://github.com/SuperTux/supertux/commit/afd5f1b33c110104a7f286d6d7854157919a0a52

This will result in the following build failure on uclibc or musl:
[ 77%] Linking C executable sq_static
CMakeFiles/sq_static.dir/sq.c.o: In function `quit':
/home/buildroot/autobuild/instance-3/output/build/supertux-0.6.0/external/squirrel/sq/sq.c:42: undefined reference to `__gnu_mcount_nc'

Fixes:
 - http://autobuild.buildroot.org/results/b0b2e25af198d01713d1e2bcf38c77ae8ffbd7de

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/supertux/supertux.mk

index af25509da8b0a44025ac4475b469e469c88ed3ee..5842b17ba470021605032eb401002ac22ca4bdb7 100644 (file)
@@ -18,6 +18,7 @@ SUPERTUX_LICENSE_FILES = LICENSE.txt data/AUTHORS
 SUPERTUX_DEPENDENCIES = host-pkgconf boost freetype libcurl libgl libglew libglu \
        libogg libpng libvorbis openal physfs sdl2 sdl2_image
 
+# CMAKE_BUILD_TYPE=Release: disable profiling code (-pg)
 # ENABLE_BOOST_STATIC_LIBS=OFF: use boost shared libraries since supertux
 # depends on !BR2_STATIC_LIBS and boost provide only shared libraries with
 # BR2_SHARED_LIBS.
@@ -28,6 +29,7 @@ SUPERTUX_DEPENDENCIES = host-pkgconf boost freetype libcurl libgl libglew libglu
 # in physfs.h (CHECK_SYMBOL_EXISTS) doesn't work.
 # ENABLE_OPENGLES2=OFF: Disable opengles2 for now.
 SUPERTUX_CONF_OPTS += \
+       -DCMAKE_BUILD_TYPE=Release \
        -DENABLE_BOOST_STATIC_LIBS=OFF \
        -DBUILD_DOCUMENTATION=OFF \
        -DENABLE_OPENGL=ON \