Merge branch 'next'
authorPeter Korsgaard <peter@korsgaard.com>
Wed, 2 Sep 2020 16:07:52 +0000 (18:07 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 2 Sep 2020 16:14:46 +0000 (18:14 +0200)
A number of merge conflicts, but hopefully they are all sorted out now.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
19 files changed:
1  2 
Config.in.legacy
DEVELOPERS
Makefile
package/capnproto/capnproto.mk
package/collectd/Config.in
package/collectd/collectd.mk
package/libcamera/libcamera.mk
package/libnss/libnss.mk
package/systemd/systemd.mk
package/x11r7/xserver_xorg-server/0001-modesettings-needs-dri2.patch
package/x11r7/xserver_xorg-server/0002-Remove-check-for-useSIGIO-option.patch
package/x11r7/xserver_xorg-server/0003-include-misc.h-fix-uClibc-build.patch
package/x11r7/xserver_xorg-server/0004-hw-xwayland-Makefile.am-fix-build-without-glx.patch
package/x11r7/xserver_xorg-server/0005-hw-xfree86-common-xf86Init.c-fix-build-without-glx.patch
package/x11r7/xserver_xorg-server/Config.in
package/x11r7/xserver_xorg-server/xserver_xorg-server.hash
package/x11r7/xserver_xorg-server/xserver_xorg-server.mk
support/misc/gitlab-ci.yml.in
toolchain/toolchain-external/Config.in

index 4e2809b562a8bc909764a83745a9d3acf03c706a,0c37b600ba1ff22a63dc334c9bacf2f841d21648..aec2633fd2b6de85da6cd5d397e7acebc96a4843
@@@ -144,18 -144,52 +144,45 @@@ endi
  
  ###############################################################################
  
+ comment "Legacy options removed in 2020.11"
+ config BR2_PACKAGE_XSERVER_XORG_SERVER_AIGLX
+       bool "X.org Enable AIGLX Extension"
+       select BR2_LEGACY
+       help
+         AIGLX Extension was removed in X.org X server version 1.19.0
+ config BR2_PACKAGE_AMD_CATALYST
+       bool "amd-catalyst"
+       select BR2_LEGACY
+       help
+         Current X.org server is incompatible with this driver.
+ config BR2_PACKAGE_NVIDIA_TEGRA23
+       bool "nvidia-tegra23 package removed"
+       select BR2_LEGACY
+       help
+         Current X.org server is incompatible with this driver.
+ config BR2_GDB_VERSION_8_1
+       bool "gdb 8.1.x has been removed"
+       select BR2_LEGACY
+       help
+         The 8.1.x version of gdb has been removed. Use a newer
+         version instead.
  comment "Legacy options removed in 2020.08"
  
 -config BR2_PACKAGE_EFL_GIF
 -      bool "efl evas gif loader is mandatory"
 +config BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_AMD64
 +      bool "toolchain-external-codesourcery-amd64 removed"
        select BR2_LEGACY
        help
 -        Since efl 1.23.x, the evas gif loader can't be disabled.
 -
 -config BR2_PACKAGE_EFL_PNG
 -      bool "efl evas png loader is mandatory"
 -      select BR2_LEGACY
 -      help
 -        Since efl 1.23.x, the evas png loader can't be disabled.
 -
 -config BR2_PACKAGE_EFL_ELPUT
 -      bool "efl elput is enabled by efl drm option"
 -      select BR2_LEGACY
 -      help
 -        Since efl 1.23.x, the drm option enable the elput library.
 +        The CodeSourcery toolchain for AMD64, in version 2016.11 was
 +        dropped, due to it using a too old gcc 6.2.0 compiler which
 +        caused issues compiling a number of recent packages
 +        (e.g. Boost). CodeSourcery has stopped making newer versions
 +        of this toolchain publicly available, so it was not possible
 +        to update it.
  
  config BR2_KERNEL_HEADERS_5_6
        bool "kernel headers version 5.6.x are no longer supported"
diff --cc DEVELOPERS
index 3c3dcda859aaa5e78e050e4ebae963b37e1a21d5,86446b9a64196692ed823d37f8265d49a43e5289..192eab8de96a9714b7ed852b76e5e0a12c8b5c1b
@@@ -1094,12 -1102,11 +1102,13 @@@ F:   package/python-cheetah
  F:    package/python-markdown/
  F:    package/python-remi/
  F:    package/python-sip/
+ F:    package/uhd/
  
  N:    Heiko Thiery <heiko.thiery@gmail.com>
 +F:    package/ipmitool/
  F:    package/libnetconf2/
  F:    package/libyang/
 +F:    package/linuxptp/
  F:    package/netopeer2/
  F:    package/sysrepo/
  
diff --cc Makefile
Simple merge
Simple merge
Simple merge
Simple merge
Simple merge
Simple merge
Simple merge
index 0000000000000000000000000000000000000000,97ec29d044fe6d9d92143a5bf023250f805feab0..74917720cbcd1485fa0289d455b5843b7c32d3bc
mode 000000,100644..100644
--- /dev/null
@@@ -1,0 -1,20 +1,20 @@@
 -@@ -2036,7 +2036,7 @@
+ Kernel modesettings support also depends on dri2, see
+ http://cgit.freedesktop.org/xorg/xserver/tree/hw/xfree86/drivers/modesetting/Makefile.am#n46
+ Patch sent upstream: https://gitlab.freedesktop.org/xorg/xserver/issues/479
+ [rebased for version 1.20.0]
+ Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
+ diff -uNr xorg-server-1.17.2.org/configure.ac xorg-server-1.17.2/configure.ac
+ --- xorg-server-1.17.2.org/configure.ac       2015-06-16 17:42:40.000000000 +0200
+ +++ xorg-server-1.17.2/configure.ac   2015-08-08 10:44:59.702382624 +0200
++@@ -1962,7 +1962,7 @@
+               XORG_SYS_LIBS="$XORG_SYS_LIBS $XORG_MODULES_LIBS"
+       fi
+  
+ -     if test "x$DRM" = xyes; then
+ +     if test "x$DRM" = xyes -a "x$DRI2" = xyes; then
+               XORG_DRIVER_MODESETTING=yes
+       fi
+  
index 0000000000000000000000000000000000000000,0000000000000000000000000000000000000000..68a9d7fc7508046c8bfa21c85ff30ab18ef50488
new file mode 100644 (file)
--- /dev/null
--- /dev/null
@@@ -1,0 -1,0 +1,53 @@@
++From cf407b16cd65ad6e26a9c8e5984e163409a5c0f7 Mon Sep 17 00:00:00 2001
++From: Prabhu Sundararaj <prabhu.sundararaj@nxp.com>
++Date: Mon, 30 Jan 2017 16:32:06 -0600
++Subject: [PATCH] Remove check for useSIGIO option
++
++Original patch follows:
++Commit 6a5a4e60373c1386b311b2a8bb666c32d68a9d99 removes the configure of useSIGIO
++option.
++
++As the xfree86 SIGIO support is reworked to use internal versions of OsBlockSIGIO
++and OsReleaseSIGIO.
++
++No longer the check for useSIGIO is needed
++
++Upstream-Status: Pending
++
++Signed-off-by: Prabhu Sundararaj <prabhu.sundararaj@nxp.com>
++
++Downloaded from
++https://github.com/openembedded/openembedded-core/blob/master/meta/recipes-graphics/xorg-xserver/xserver-xorg/0003-Remove-check-for-useSIGIO-option.patch
++
++Signed-off-by: Mylène Josserand <mylene.josserand@free-electrons.com>
++---
++ hw/xfree86/os-support/shared/sigio.c | 6 ------
++ 1 file changed, 6 deletions(-)
++
++diff --git a/hw/xfree86/os-support/shared/sigio.c b/hw/xfree86/os-support/shared/sigio.c
++index 884a71c..be76498 100644
++--- a/hw/xfree86/os-support/shared/sigio.c
+++++ b/hw/xfree86/os-support/shared/sigio.c
++@@ -185,9 +185,6 @@ xf86InstallSIGIOHandler(int fd, void (*f) (int, void *), void *closure)
++     int i;
++     int installed = FALSE;
++ 
++-    if (!xf86Info.useSIGIO)
++-        return 0;
++-
++     for (i = 0; i < MAX_FUNCS; i++) {
++         if (!xf86SigIOFuncs[i].f) {
++             if (xf86IsPipe(fd))
++@@ -257,9 +256,6 @@ xf86RemoveSIGIOHandler(int fd)
++     int max;
++     int ret;
++ 
++-    if (!xf86Info.useSIGIO)
++-        return 0;
++-
++     max = 0;
++     ret = 0;
++     for (i = 0; i < MAX_FUNCS; i++) {
++-- 
++2.7.4
++
index 0000000000000000000000000000000000000000,0000000000000000000000000000000000000000..562aa79fbb7e792c4a8538dd58da576acec12d7f
new file mode 100644 (file)
--- /dev/null
--- /dev/null
@@@ -1,0 -1,0 +1,31 @@@
++From 2e8fca00f5bdb02f2f59aaa428d1e9d808ab0e86 Mon Sep 17 00:00:00 2001
++From: Bernd Kuhls <bernd.kuhls@t-online.de>
++Date: Sat, 16 Jun 2018 19:20:16 +0200
++Subject: [PATCH] include/misc.h: fix uClibc build
++
++A similar fix was used for Dovecot:
++https://www.dovecot.org/list/dovecot/2017-November/110019.html
++
++Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
++---
++ include/misc.h | 4 ++++
++ 1 file changed, 4 insertions(+)
++
++diff --git a/include/misc.h b/include/misc.h
++index 14920c3c3..390e52b60 100644
++--- a/include/misc.h
+++++ b/include/misc.h
++@@ -185,6 +185,10 @@ typedef struct _xReq *xReqPtr;
++ #endif
++ #endif
++ 
+++#undef bswap_16
+++#undef bswap_32
+++#undef bswap_64
+++
++ /**
++  * Calculate the number of bytes needed to hold bits.
++  * @param bits The minimum number of bits needed.
++-- 
++2.17.1
++
index 0000000000000000000000000000000000000000,0000000000000000000000000000000000000000..5f19a26d14769bed7bf40c66ed247158364d2220
new file mode 100644 (file)
--- /dev/null
--- /dev/null
@@@ -1,0 -1,0 +1,45 @@@
++From b1d2a82d644518c1a75775244ac63be738aaf062 Mon Sep 17 00:00:00 2001
++From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
++Date: Fri, 19 Apr 2019 10:19:50 +0200
++Subject: [PATCH] hw/xwayland/Makefile.am: fix build without glx
++
++Commit d8ec33fe0542141aed1d9016d2ecaf52da944b4b added libglxvnd.la to
++Xwayland_LDFLAGS but GLX can be disabled through --disable-glx.
++In this case, build fails on:
++
++make[3]: *** No rule to make target '../../glx/libglxvnd.la', needed by 'Xwayland'.  Stop.
++make[3]: *** Waiting for unfinished jobs....
++
++Fixes:
++ - http://autobuild.buildroot.org/results/397f8098c57fc6c88aa12dc8d35ebb1b933d52ef
++
++Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
++[Upstream status:
++https://gitlab.freedesktop.org/xorg/xserver/merge_requests/173]
++---
++ hw/xwayland/Makefile.am | 6 +++++-
++ 1 file changed, 5 insertions(+), 1 deletion(-)
++
++diff --git a/hw/xwayland/Makefile.am b/hw/xwayland/Makefile.am
++index bc1cb8506..502879e2a 100644
++--- a/hw/xwayland/Makefile.am
+++++ b/hw/xwayland/Makefile.am
++@@ -21,10 +21,14 @@ Xwayland_SOURCES =                                \
++      $(top_srcdir)/Xi/stubs.c                \
++      $(top_srcdir)/mi/miinitext.c
++ 
+++if GLX
+++GLXVND_LIB = $(top_builddir)/glx/libglxvnd.la
+++endif
+++
++ Xwayland_LDADD =                             \
++      $(glamor_lib)                           \
++      $(XWAYLAND_LIBS)                        \
++-     $(top_builddir)/glx/libglxvnd.la        \
+++     $(GLXVND_LIB)                           \
++      $(XWAYLAND_SYS_LIBS)                    \
++      $(top_builddir)/Xext/libXvidmode.la     \
++      $(XSERVER_SYS_LIBS)
++-- 
++2.20.1
++
index 0000000000000000000000000000000000000000,0000000000000000000000000000000000000000..de086fb6655f0e73edaa60aa20e98a86fcf210d1
new file mode 100644 (file)
--- /dev/null
--- /dev/null
@@@ -1,0 -1,0 +1,45 @@@
++From 49456e0a37fac7bc9d1f01bc1519fb0d699956db Mon Sep 17 00:00:00 2001
++From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
++Date: Fri, 27 Dec 2019 23:33:37 +0100
++Subject: [PATCH] hw/xfree86/common/xf86Init.c: fix build without glx
++
++Since commit d8ec33fe0542141aed1d9016d2ecaf52da944b4b, an include on
++glxvndabi.h has been added to hw/xfree86/common/xf86Init.c
++
++However, if glx is disabled through --disable-glx and GLX headers are
++not installed in the build's environment, build fails on:
++
++In file included from xf86Init.c:81:
++../../../include/glxvndabi.h:64:10: fatal error: GL/glxproto.h: No such file or directory
++   64 | #include <GL/glxproto.h>
++      |          ^~~~~~~~~~~~~~~
++
++Fix this failure by removing this include which does not seem to be
++needed (an other option would have been to keep it under an ifdef GLXEXT
++block)
++
++Fixes:
++ - http://autobuild.buildroot.org/results/de838a843f97673d1381a55fd4e9b07164693913
++
++Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
++[Retrieved from:
++https://gitlab.freedesktop.org/xorg/xserver/commit/49456e0a37fac7bc9d1f01bc1519fb0d699956db]
++---
++ hw/xfree86/common/xf86Init.c | 1 -
++ 1 file changed, 1 deletion(-)
++
++diff --git a/hw/xfree86/common/xf86Init.c b/hw/xfree86/common/xf86Init.c
++index 0631c7237..e6fb11398 100644
++--- a/hw/xfree86/common/xf86Init.c
+++++ b/hw/xfree86/common/xf86Init.c
++@@ -78,7 +78,6 @@
++ #include "xf86InPriv.h"
++ #include "picturestr.h"
++ #include "randrstr.h"
++-#include "glxvndabi.h"
++ #include "xf86Bus.h"
++ #ifdef XSERVER_LIBPCIACCESS
++ #include "xf86VGAarbiter.h"
++-- 
++2.24.1
++
index 87f1b37daf29db63edd807d0ebe49e647f9254c0,e3056683cc6267e3bf9e9d2659fa386c16cac20d..d53083ef9016a8a1863382a0382aa4a64a2ac9c5
@@@ -40,49 -40,6 +40,8 @@@ config BR2_PACKAGE_XSERVER_XORG_SERVE
  
          http://xorg.freedesktop.org
  
- config BR2_PACKAGE_XSERVER_XORG_SERVER_VIDEODRV_ABI_14
-       bool
- config BR2_PACKAGE_XSERVER_XORG_SERVER_VIDEODRV_ABI_19
-       bool
- config BR2_PACKAGE_XSERVER_XORG_SERVER_VIDEODRV_ABI_24
-       bool
- config BR2_PACKAGE_XSERVER_XORG_SERVER_VIDEODRV_ABI
-       int
-       default 14 if BR2_PACKAGE_XSERVER_XORG_SERVER_VIDEODRV_ABI_14
-       default 19 if BR2_PACKAGE_XSERVER_XORG_SERVER_VIDEODRV_ABI_19
-       default 24 if BR2_PACKAGE_XSERVER_XORG_SERVER_VIDEODRV_ABI_24
- choice
-       bool "X Window System server version"
- config BR2_PACKAGE_XSERVER_XORG_SERVER_V_1_20
-       bool "1.20.9"
-       select BR2_PACKAGE_XSERVER_XORG_SERVER_VIDEODRV_ABI_24
-       select BR2_PACKAGE_XLIB_LIBXFONT2
- config BR2_PACKAGE_XSERVER_XORG_SERVER_V_1_17
-       bool "1.17.4"
-       select BR2_PACKAGE_XSERVER_XORG_SERVER_VIDEODRV_ABI_19
-       select BR2_PACKAGE_XLIB_LIBXFONT
- config BR2_PACKAGE_XSERVER_XORG_SERVER_V_1_14
-       bool "1.14.7"
-       select BR2_PACKAGE_XSERVER_XORG_SERVER_VIDEODRV_ABI_14
-       select BR2_PACKAGE_XLIB_LIBXFONT
- endchoice
- config BR2_PACKAGE_XSERVER_XORG_SERVER_VERSION
-       string
-       default "1.20.9" if BR2_PACKAGE_XSERVER_XORG_SERVER_V_1_20
-       default "1.17.4" if BR2_PACKAGE_XSERVER_XORG_SERVER_V_1_17
-       default "1.14.7" if BR2_PACKAGE_XSERVER_XORG_SERVER_V_1_14
 +if BR2_PACKAGE_XSERVER_XORG_SERVER
 +
  choice
        prompt "X Window System server type"
        help
index 930900c5ea26f7b946b8e272d614c7a2a7aad64f,7d75853c62a616af2cbedc69eb7f6f9e780023dc..2b55449e14e5c83e220ec4447e83d586f83306ff
@@@ -1,11 -1,6 +1,6 @@@
- # From http://lists.x.org/archives/xorg-announce/2014-June/002440.html
- sha1  7a95765e56b124758fcd7b609589e65b8870880b  xorg-server-1.14.7.tar.bz2
- sha256  fcf66fa6ad86227613d2d3e8ae13ded297e2a1e947e9060a083eaf80d323451f  xorg-server-1.14.7.tar.bz2
- # From https://lists.x.org/archives/xorg-announce/2015-October/002650.html
- sha256  0c4b45c116a812a996eb432d8508cf26c2ec8c3916ff2a50781796882f8d6457  xorg-server-1.17.4.tar.bz2
 -# From https://lists.x.org/archives/xorg-announce/2020-March/003041.html
 -sha256 d17b646bee4ba0fb7850c1cc55b18e3e8513ed5c02bdf38da7e107f84e2d0146  xorg-server-1.20.8.tar.bz2
 -sha512 ab0ec0fcbf490c61558b9297f61b58fd2dedb676c78bef6431dc9166054743b43a0091b88a8b3f4e81d1f539909440ee7e188a298cefabe13ea89159639cd805  xorg-server-1.20.8.tar.bz2
 +# From https://lists.x.org/archives/xorg-announce/2020-August/003059.html
 +sha256  e219f2e0dfe455467939149d7cd2ee53b79b512cc1d2094ae4f5c9ed9ccd3571  xorg-server-1.20.9.tar.bz2
 +sha512  d9b5f93e1b9763a89187d8b272aa7d4ce9709641b8539f4536708af153310e5a4931bffd4229c51a3b0e3b12da7838750aa71b635751fb4c0bb27438cce4e5e6  xorg-server-1.20.9.tar.bz2
  
  # Locally calculated
 -sha256 4cc0447a22635c7b2f1a93fec4aa94f1970fadeb72a063de006b51cf4963a06f  COPYING
 +sha256  4cc0447a22635c7b2f1a93fec4aa94f1970fadeb72a063de006b51cf4963a06f  COPYING
Simple merge
index 424ffec6830c83a80df6bd478f254cac4cfd6cd7,c4fac32d24c16ebbc1cb4e06294421bfd951eef8..2177e6a6784f67a58b6bd42671612ec2d7c0ca84
@@@ -42,6 -42,12 +42,9 @@@ source "toolchain/toolchain-external/to
  # NIOSII
  source "toolchain/toolchain-external/toolchain-external-codesourcery-niosII/Config.in"
  
 -# x86_64
 -source "toolchain/toolchain-external/toolchain-external-codesourcery-amd64/Config.in"
 -
+ # Bootlin toolchains, available for virtually all architectures
+ source "toolchain/toolchain-external/toolchain-external-bootlin/Config.in"
  # Kept last, so it remains the non-default choice, unless there isn't
  # any available toolchain profile for the currently selected
  # architecture, but before toolchains from br2-external trees.
@@@ -146,6 -152,12 +149,9 @@@ source "toolchain/toolchain-external/to
  # NIOSII
  source "toolchain/toolchain-external/toolchain-external-codesourcery-niosII/Config.in.options"
  
 -# x86_64
 -source "toolchain/toolchain-external/toolchain-external-codesourcery-amd64/Config.in.options"
 -
+ # Bootlin toolchains
+ source "toolchain/toolchain-external/toolchain-external-bootlin/Config.in.options"
  # Custom toolchains
  source "toolchain/toolchain-external/toolchain-external-custom/Config.in.options"