packages infra: add function to get a Kconfig option
authorYann E. MORIN <yann.morin.1998@free.fr>
Sat, 8 Feb 2014 16:26:04 +0000 (17:26 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 3 Mar 2014 21:21:56 +0000 (22:21 +0100)
We so far have no mean to get the value from a Kconfig option from the
.config file of a package (eg. linux, busybox...).

Add a new function that returns the unmangled value of an option.
It expect two arguments:
  - the Kconfig option name (complete, with leading CONFIG if necessary)
  - the .config file to get it from

Note that, if the Kconfig option is a string, the returned value will
contain the leading and trailing double-quotes.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Peter Korsgaard <jacmet@uclibc.org>
Cc: Arnout Vandecappelle <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/pkg-utils.mk

index 91a198160fd4bad3f74f05bae27ead73376963d9..99fefe6a448eb17ac912228940fcc7cfa59f9e41 100644 (file)
@@ -52,6 +52,8 @@ define KCONFIG_DISABLE_OPT
        echo "# $(1) is not set" >> $(2)
 endef
 
+KCONFIG_GET_OPT = $(shell sed -e 's/^$(1)=//p' $(2))
+
 # Helper functions to determine the name of a package and its
 # directory from its makefile directory, using the $(MAKEFILE_LIST)
 # variable provided by make. This is used by the *TARGETS macros to