iproute2: tipc support needs 3.18+ headers
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 29 Jun 2015 12:45:54 +0000 (09:45 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 29 Jun 2015 19:59:06 +0000 (21:59 +0200)
Fixes:
http://autobuild.buildroot.net/results/173/173c9dbed6422a3cc4f9d1f998bc25ce2e9538c7/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/iproute2/iproute2.mk

index dabc8b41bf4bba339d289912bd127054a699f23a..b2627ec621954ee04cd3c5ed5e88702a739faddf 100644 (file)
@@ -17,8 +17,13 @@ ifeq ($(BR2_PACKAGE_BUSYBOX),y)
 IPROUTE2_DEPENDENCIES += busybox
 endif
 
-ifeq ($(BR2_PACKAGE_LIBMNL),y)
+# tipc support needs 3.18+ headers and libmnl
+ifeq ($(BR2_PACKAGE_LIBMNL)$(BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_18),yy)
 IPROUTE2_DEPENDENCIES += libmnl
+else
+define IPROUTE2_DISABLE_TIPC
+       $(SED) '/HAVE_MNL/d' $(@D)/Config
+endef
 endif
 
 # If we've got iptables enable xtables support for tc
@@ -57,6 +62,7 @@ define IPROUTE2_CONFIGURE_CMDS
        cd $(@D) && $(TARGET_CONFIGURE_OPTS) ./configure
        $(IPROUTE2_DISABLE_ARPD)
        $(IPROUTE2_WITH_IPTABLES)
+       $(IPROUTE2_DISABLE_TIPC)
 endef
 
 define IPROUTE2_BUILD_CMDS