libunistring: new package
authorPedro Aguilar <paguilar@paguilar.org>
Sun, 19 Oct 2014 22:36:53 +0000 (00:36 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 25 Oct 2014 17:29:25 +0000 (19:29 +0200)
[Thomas:
  - adjust the title of the commit
  - remove the thread dependency, by using the --disable-threads
    option when needed
  - remove LIBUNISTRING_SOURCE, since its value was the default
  - use BR2_GNU_MIRROR in LIBUNISTRING_SITE
  - adjust the license, which really is LGPLv3+, not LGPLv2. The
    license file is COPYING.LIB.]

Signed-off-by: Pedro Aguilar <paguilar@paguilar.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/libunistring/Config.in [new file with mode: 0644]
package/libunistring/libunistring.mk [new file with mode: 0644]

index 03639e43d1e624b53b0a98c14d2b6c69c6dcfaf7..9e361b94695a1ee411bc4af90d88eec4be6f24fe 100644 (file)
@@ -907,6 +907,7 @@ menu "Other"
        source "package/startup-notification/Config.in"
        source "package/tz/Config.in"
        source "package/tzdata/Config.in"
+       source "package/libunistring/Config.in"
 endmenu
 
 menu "Security"
diff --git a/package/libunistring/Config.in b/package/libunistring/Config.in
new file mode 100644 (file)
index 0000000..ebb37d9
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_LIBUNISTRING
+       bool "libunistring"
+       help
+         The libunistring library provides functions for manipulating
+         Unicode strings and for manipulating C strings according to
+         the Unicode standard.
+
+         http://www.gnu.org/software/libunistring/
diff --git a/package/libunistring/libunistring.mk b/package/libunistring/libunistring.mk
new file mode 100644 (file)
index 0000000..3234ddc
--- /dev/null
@@ -0,0 +1,19 @@
+################################################################################
+#
+# libunistring
+#
+################################################################################
+
+LIBUNISTRING_VERSION = 0.9.4
+LIBUNISTRING_SITE = $(BR2_GNU_MIRROR)/libunistring
+LIBUNISTRING_INSTALL_STAGING = YES
+LIBUNISTRING_LICENSE = LGPLv3+
+LIBUNISTRING_LICENSE_FILES = COPYING.LIB
+
+ifeq ($(BR2_TOOLCHAIN_HAS_THREADS),y)
+LIBUNISTRING_CONF_OPTS += --enable-threads=posix
+else
+LIBUNISTRING_CONF_OPTS += --disable-threads
+endif
+
+$(eval $(autotools-package))