package/sqlcipher: fix static build with openssl and atomic
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 13 Apr 2019 15:00:05 +0000 (17:00 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 13 Apr 2019 19:14:13 +0000 (21:14 +0200)
Use pkg-config to find openssl dependencies such as lz or latomic

Fixes: static build on sparc v8 (even if there are no autobuilder
failures yet)

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/sqlcipher/sqlcipher.mk

index 44273441202759bbdfceb0aaf8e0c74f4d3d4ed9..a16d94d1dcc789fd62d100c1bd2fa680ce7203e1 100644 (file)
@@ -8,7 +8,7 @@ SQLCIPHER_VERSION = v4.0.1
 SQLCIPHER_SITE = $(call github,sqlcipher,sqlcipher,$(SQLCIPHER_VERSION))
 SQLCIPHER_LICENSE = BSD-3-Clause
 SQLCIPHER_LICENSE_FILES = LICENSE
-SQLCIPHER_DEPENDENCIES = openssl host-tcl
+SQLCIPHER_DEPENDENCIES = host-pkgconf openssl host-tcl
 SQLCIPHER_INSTALL_STAGING = YES
 
 SQLCIPHER_CONF_ENV = \
@@ -20,7 +20,7 @@ SQLCIPHER_CONF_OPTS = \
        --disable-tcl
 
 SQLCIPHER_CFLAGS += -DSQLITE_HAS_CODEC # Required according to the README
-SQLCIPHER_CONF_ENV += LIBS="-lcrypto -lz"
+SQLCIPHER_CONF_ENV += LIBS=`$(PKG_CONFIG_HOST_BINARY) --libs openssl`
 
 ifeq ($(BR2_PACKAGE_SQLCIPHER_STAT3),y)
 SQLCIPHER_CFLAGS += -DSQLITE_ENABLE_STAT3