package/busybox: enable flags for use as systemd pager
authorNorbert Lange <nolange79@gmail.com>
Fri, 17 Jul 2020 10:18:36 +0000 (12:18 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 6 Aug 2020 08:00:56 +0000 (10:00 +0200)
If the less package is not enable and systemd is enabled,
then configure the less applet to fully work with systemd.

systemd sets the flags for less in an environment variable
and requires a few options for correct display.

Signed-off-by: Norbert Lange <nolange79@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/busybox/busybox.mk

index 24f3ba3b19a56f202cd0fed280388109225342d9..7a1a50696337fa5644eb1c4a837b87d964fe9c45 100644 (file)
@@ -236,6 +236,18 @@ define BUSYBOX_SET_SELINUX
 endef
 endif
 
+# enable relevant options to allow the Busybox less applet to be used
+# as a systemd pager
+ifeq ($(BR2_PACKAGE_SYSTEMD):$(BR2_PACKAGE_LESS),y:)
+define BUSYBOX_SET_LESS_FLAGS
+       $(call KCONFIG_ENABLE_OPT,CONFIG_FEATURE_LESS_DASHCMD)
+       $(call KCONFIG_ENABLE_OPT,CONFIG_FEATURE_LESS_RAW)
+       $(call KCONFIG_ENABLE_OPT,CONFIG_FEATURE_LESS_TRUNCATE)
+       $(call KCONFIG_ENABLE_OPT,CONFIG_FEATURE_LESS_FLAGS)
+       $(call KCONFIG_ENABLE_OPT,CONFIG_FEATURE_LESS_ENV)
+endef
+endif
+
 ifeq ($(BR2_PACKAGE_BUSYBOX_INDIVIDUAL_BINARIES),y)
 define BUSYBOX_SET_INDIVIDUAL_BINARIES
        $(call KCONFIG_ENABLE_OPT,CONFIG_BUILD_LIBBUSYBOX)
@@ -337,6 +349,7 @@ define BUSYBOX_KCONFIG_FIXUP_CMDS
        $(BUSYBOX_SET_INIT)
        $(BUSYBOX_SET_WATCHDOG)
        $(BUSYBOX_SET_SELINUX)
+       $(BUSYBOX_SET_LESS_FLAGS)
        $(BUSYBOX_SET_INDIVIDUAL_BINARIES)
 endef