libaio: add host variant
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 16 Aug 2018 09:29:43 +0000 (11:29 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 21 Aug 2018 09:47:10 +0000 (11:47 +0200)
Since the bump of lvm2 to 2.02.180 in commit
8e666bf29e762f3c7681a48d0ee350f8396d798f, lvm2 needs libaio. This was
properly taken into account for the target lvm2 variant, but not the
host lvm2 variant. In order to build the host lvm2, we now need
host-libaio, so this patch adds support for building libaio for the
host.

Part of fixing:

  http://autobuild.buildroot.net/results/f95dd353c17bdfd00fde6762e58aa32e6830b52b/

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libaio/libaio.mk

index 03029d84d86b892114edd9ffb111c4558013515a..76e6937cc20fd19a03445ef6adaf07adc0a36b15 100644 (file)
@@ -35,4 +35,13 @@ define LIBAIO_INSTALL_TARGET_CMDS
        $(LIBAIO_CONFIGURE_OPTS) $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) DESTDIR=$(TARGET_DIR) install
 endef
 
+define HOST_LIBAIO_BUILD_CMDS
+       $(HOST_CONFIGURE_OPTS) $(HOST_MAKE_ENV) $(MAKE) -C $(@D)
+endef
+
+define HOST_LIBAIO_INSTALL_CMDS
+       $(HOST_CONFIGURE_OPTS) $(HOST_MAKE_ENV) $(MAKE) -C $(@D) prefix=$(HOST_DIR) install
+endef
+
 $(eval $(generic-package))
+$(eval $(host-generic-package))